VirtualBox

Ticket #8909 (closed defect: invalid)

Opened 3 years ago

Last modified 3 years ago

graphical corruption when moving windows -> X.Org bug

Reported by: yrro Owned by:
Priority: minor Component: GUI
Version: VirtualBox 4.0.8 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Since upgrading to 4.0.4 (also with 4.0.6 and 4.0.8 albeit with the guest additions from 4.0.4), when I move a window the contents get corrupted.

Guest is Debian using Linux 2.6.32.

Attachments

corruption.png Download (9.4 KB) - added by yrro 3 years ago.
screenshot of a corrupted window
wintermute-2011-05-29-15-58-39.log Download (109.6 KB) - added by yrro 3 years ago.
log file

Change History

Changed 3 years ago by yrro

screenshot of a corrupted window

comment:1 Changed 3 years ago by michael

Could you please attach a log file from a VM run? And are you using 3D on the guest?

comment:2 Changed 3 years ago by yrro

3D is disabled in the guest.

Further experimentation reveals that windows are invariably corrupted when they are being moved towards the left of the screen (either by being dragged with the mouse, or moved with the keyboard).

Changed 3 years ago by yrro

log file

comment:3 Changed 3 years ago by yrro

I no longer think this is a bug in VirtualBox. It appears to be caused by Xorg calling memcpy with overlapping source and destination regions.

ref:  https://bugs.debian.org/626682

comment:4 Changed 3 years ago by michael

  • Status changed from new to closed
  • Resolution set to invalid
  • Summary changed from graphical corruption when moving windows to graphical corruption when moving windows -> X.Org bug

Thanks for letting us know. I will close this ticket then. Were you able to do the pre-load library test described in the Debian ticket?

comment:5 Changed 3 years ago by yrro

Yes, that's how I diagnosed the problem. The preload library is a great workaround until it's fixed.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use