VirtualBox

Ticket #8859 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

vboxdrv: 'Default Stop'-value causing trouble on recent Debian and derivatives -> fixed as of 2 Aug 2011

Reported by: pema Owned by:
Priority: major Component: host support
Version: VirtualBox 4.0.6 Keywords:
Cc: Guest type: other
Host type: Linux

Description

The "Default Stop" comment of vboxdrv comprises just run level 1.

On Debian lenny symbolic links K*vboxdrv are established in /etc/rc{0,1,6}.d nevertheless.
On Debian squeeze, a link K*vboxdrv is created in /etc/rc1.d only. Moreover, installing VirtualBox yields an error message

update-rc.d: warning: vboxdrv stop runlevel arguments (0 1 6) do not match LSB Default-Stop values (1)

which can be reproduced by running update-rc.d vboxdrv defaults.
The difference between lenny and squeeze is probably caused by different default behavior of update-rc.d.
Btw. I consider this error message to be buggy itself - should be "... arguments (1) ... values (0 1 6)".

According to  http://forums.virtualbox.org/viewtopic.php?f=7&t=37659 Debian derivates seem to be affcted, too.

All other init-scripts belonging to VirtualBox 4.0.6 define 0, 1 and 6 as stop-runlevels, same thing for all init-scripts included in 3.2.12.

Change History

comment:1 Changed 3 years ago by nh2

Confirmed on Ubuntu 11.04. Could you please fix your packages?

comment:2 Changed 3 years ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from vboxdrv: 'Default Stop'-value causing trouble on recent Debian and derivatives to vboxdrv: 'Default Stop'-value causing trouble on recent Debian and derivatives -> fixed as of 2 Aug 2011

This was fixed a while ago and the fix will be included in any future releases. I find it slightly silly, as there is nothing that we need to do before shutdown (I thought the current wisdom was to only do important things so as not to waste time), but if they insist then fine.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use