Ticket #8858 (closed defect: obsolete)

Opened 8 years ago

Last modified 2 years ago

Ubuntu 11.04 guest fullscreen graphics are broken with 3D enabled

Reported by: wjbuys Owned by:
Component: 3D support Version: VirtualBox 4.0.6
Keywords: compiz unity ubuntu windows 3d fullscreen Cc:
Guest type: Linux Host type: Windows

Description (last modified by aeichner) (diff)

  • Software:
    • VirtualBox 4.0.6, Windows 7 (64bit) host,
    • Ubuntu 11.04 Desktop (32bit GA) guest with 4.0.6 additions installed with DKMS.
  • Hardware:
    • Lenovo T510 laptop,
    • Intel GMA HD graphics,
    • Latest BIOS and graphics drivers.

My goal is to get Unity working, which requires 3D support.

3D acceleration works fine in windowed mode, even when maximized. Hovewer, when I then attempt to go to fullscreen mode, the guest display no longer redraws or responds properly: it looks like it's not drawing any 3D effects, and only redraws the screen when they have ended. If I leave fullscreen mode, everything works properly again.

Sometimes, entering, leaving and entering fullscreen mode in quick succession solves the redrawing problem, but keeps the resolution the same as it was in windowed mode.

Booting the VM into fullscreen mode has the same problem.

The problem does not occur when 3D acceleration is disabled (but then obviously compiz/unity does not work).

This problem is present in all 4.0.x versions of VirtualBox (I have not tested older versions than 4.0.0).


VBox-3D-fullscreen-fail.log Download (85.3 KB) - added by wjbuys 8 years ago.
VBox-Ubuntu10.10-crashdump.7z Download (288.3 KB) - added by wjbuys 8 years ago.
VBox-Ubuntu10.10.log Download (59.7 KB) - added by wjbuys 8 years ago.

Change History

Changed 8 years ago by wjbuys

comment:1 Changed 8 years ago by wjbuys

A similar problem exists when using an Ubuntu 10.10 guest with 3D and Compiz enabled, except that it crashes when trying to leave fullscreen mode.

Changed 8 years ago by wjbuys

Changed 8 years ago by wjbuys

comment:2 follow-up: ↓ 3 Changed 8 years ago by porst17

I can confirm this behavior on VirtualBox 4.0.10 with almost the same settings (Win7 64bit host with NVidia GeForce GT 335M, Ubuntu 11.04 guest). Windowed mode works well. As soon as I switch to fullscreen mode, the screen is not updated properly anymore.

Is there any success with this problem? Maybe I can also contribute some logs, if this would help.

comment:3 in reply to: ↑ 2 Changed 8 years ago by lumpilump

Replying to porst17:

Windowed mode works well. As soon as I switch to fullscreen mode, the screen is not updated properly anymore.

I can confirm the problems, too. Windows 7 32Bit, Intel HD Graphics. VirtualBox 4.0.4 and 4.0.10 with Ubuntu 11.04 guest. Exactly the same behavior.

comment:4 Changed 8 years ago by wjbuys

Still broken in 4.12.

comment:5 Changed 7 years ago by Eldan

I can confirm this issue in 4.0.12 and 4.1.0 with Fedora 15/GNOME 3 Shell. Windowed mode is fine, fullscreen mode is broken.

comment:6 Changed 7 years ago by sffetlio

I have the same problem. Windowed mode is OK, even maximized. Full screen mode works bit the screen doesn't update when it should. Moving the mouse or clicking somewhere sometimes refreshes the screen once. After leaving full screen mode it works again.

Vbox 4.1.10 with GA Ubuntu 11.10 64Bit guest, Windows 7 Professional 64Bit host, both updated HP Pavilion dv6 with latest bios and driver updates from hp

comment:7 Changed 7 years ago by sffetlio

I found a workaround which worked for me.

comment:8 Changed 6 years ago by wulftone

I'm having the same issue. Fullscreen is extremely slow. I'm on a brand new machine: Lenovo Yoga 13. I'm using VirtualBox 4.2.4r81684 and running Linux Mint 13 Maya with Cinnamon desktop (which is based on Gnome Shell, I believe).

It works fine in windowed or seamless modes. Since Cinnamon isn't using Compiz, I can't use the suggested workaround.

Is there an actual solution to this?


edit: Nevermind my previous edit, it still fails in fullscreen when the resolution is 1600x900. Strangely, it was fine when the resolution was the oddball 1600x765 (or something, it wasn't 1600x768, it was a non-standard vertical pixel count). Now I'm more confused.

Version 3, edited 6 years ago by wulftone (previous) (next) (diff)

comment:9 Changed 6 years ago by kamchacta613

I am having the exact same issue. Lenovo T430 with nvidia nvs 5400M. Host: Windows 7 Ultimate 64bit. Guest: Ubuntu 12.04 with guest additions. vbox: 4.2.4 r81684.

comment:10 Changed 5 years ago by ES

Same issue with Ubuntu 12.04 32-bit. Maximized windows work fine, but full-screen does not update.


  • ThinkPad T430s
  • Windows 7 Enterprise 64-bit
  • Intel HD 4000 @ 1600*900
  • Latest BIOs and graphics driverss
  • VirtualBox 4.2.16 r86992


  • Ubuntu 12.04 Desktop (32-bit)
  • 3.5.0-37-generic
  • 256MiB video memory (edited .vbox -- tried 128MiB as well)
  • VirtualBox additions 4.2.16 r86992

comment:11 Changed 2 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)

Please reopen if still relevant with a recent VirtualBox release.

Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use