VirtualBox

Ticket #8845 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

win7 guest freezes after a while

Reported by: hetz Owned by:
Priority: major Component: VM control
Version: VirtualBox 4.0.6 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I'm using Fedora 14 (X86) as host and win7 (32 bits as host). I installed win7, disabled 3D, office 2003 and IE9. I basically open a windows with 2-3 tabs and just leave it open on pages with flash, and it's being freezing after a while. The problem does not affect the host OS at all, and I don't see anything special in the Log file (I'm enclosing it). In terms of hardware, I tried with 2 graphic cards: Geforce 8800 and GT 210, 6GB RAM, Core2Duo E8300 processor. Guest OS: Windows 7 32 bits, 1.5GB RAM,40GB disk (dynamic).

Log file enclosed

Attachments

VBox.log.1 Download (78.8 KB) - added by hetz 3 years ago.

Change History

Changed 3 years ago by hetz

comment:1 Changed 3 years ago by hetz

Some more info: When the guest is frozen (I disabled any power managment option in the guest) the VirtualBox is using ~104% CPU. I can access the virtualization menus (reboot, power off, seamless mode, etc) but nothing can be done on the guest inside.

comment:2 Changed 3 years ago by hetz

After further investigation, it seems the freeze is not related to specific OS: I tried also Windows XP and had the same issue. Also, the kernel I'm using is the kernel that is installed by the fedora updates (2.6.35.12-90.fc14.i686.PAE without any patches, only with the nvidia driver)

comment:3 Changed 3 years ago by frank

Is there anything in the host kernel log (dmesg)?

comment:4 Changed 3 years ago by frank

You say that you can access the menu. Does the close dialog also appear and are you able to pause / continue your VM?

comment:5 Changed 3 years ago by hetz

Nothing on dmesg. Pause/Unpause seems to work (in pause the machine is black & white), but unpausing the machine after it's stuck doesn't make it continue. It still stuck with VirtualBox take +100% CPU.

comment:6 Changed 3 years ago by frank

In that case, could you provide a Core_dump when this freeze happened? If so, please contact me via frank _dot_ mehnert _at_ oracle _dot_ com, I can tell you an FTP server for uploading the file.

comment:7 Changed 3 years ago by hetz

I'll be happy to supply a core dump, but the problem is that technically it's not crashing, it's just freezing (I thought it was a hardware problem, so I replaced the CPU fan and the graphics card - didn't help at all).

comment:8 Changed 3 years ago by frank

Yes, I understand that the VM does not crash. But what you describe (unpausing does not work) looks like a deadlock so the thread state of all threads would be interesting. The mentioned page describes how to force the VM to abort and generate a core dump.

comment:9 Changed 3 years ago by hetz

Ok. I created the core dump. You can download it at:  http://benhamo.org/dl/core.vbox.gz

comment:10 Changed 3 years ago by frank

Thanks for the core dump. Unfortunately I don't see any misbehavior. If VBox currently hogging the CPU then it is executing guest code. Is there anything you did in particular with the VM when this freeze occurred?

comment:11 Changed 3 years ago by hetz

No, even when the VM set idle and did really nothing, it froze. Now here is an interesting part: I did the part that you wrote in the page about creating core, and since then the VM is actually started working well (I only had 1 freeze while playing full screen video). I just finished editing an image with Photoshop and the machine is still running. Any tips of the change??

comment:12 Changed 3 years ago by frank

Is this problem still reproducible with VBox 4.0.12?

comment:13 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use