VirtualBox

Ticket #8839 (closed defect: invalid)

Opened 3 years ago

Last modified 3 years ago

VLAN support in Solaris Express 11

Reported by: sbrickey Owned by:
Priority: major Component: network
Version: VirtualBox 4.0.6 Keywords:
Cc: Guest type: Windows
Host type: Solaris

Description

OS: Solaris Express 11, snv_151a VBox: 4.0.6

Server has two NICs, rge0 and rge1. rge0 is intended as host NIC, rge1 is intended for VMs. rge1 to use VLANs (802.1Q). Configured VLANs (11, 16, 17) using dladm. did NOT plumb the VLANs (again, host gets rge0, not rge1 or any of its tagged VLANs).

when attaching VMs to any of the tagged VLANs, VM is unable to obtain IP address. VM Guest OS: Windows 2008 R2.

Tried plumbing the VLANs briefly to test whether error was in the host/hardware or in the VMs... once plumbed, host is able to obtain IP from DHCP (and ping) without error. Attempted troubleshooting within VM guest, no resolution.

Attachments

ifconfig.txt Download (1.4 KB) - added by rlaager 3 years ago.

Change History

comment:1 Changed 3 years ago by ramshankar

You need to use PPA-hack based VLANs to work with the existing STREAMS driver, vanity named VLANs are not supported due to technical restrictions.

Please show output of sudo ifconfig -a and dladm show-link.

comment:2 Changed 3 years ago by rlaager

I'm having the same issue. I can use the vlan interface from the host, but bridging it to the guests does not work. Bridging a physical interface to the guest worked.

I'll attach the output of the commands you referenced. I initially named these interfaces br7 and br3, as that would match our existing Linux virtualization hosts. Since that didn't work and I found this ticket, I deleted br3 and recreated it using dladm create-vlan -v 3 -l e1000g0 e1000g3000. (I couldn't get it to delete br7. It kept saying "link busy" even when I removed the default route, did an ipadm delete-addr, and unplumbed the interface.) Even with a PPA-hack name, it still doesn't work.

I can't actually create a PPA-hack interface, from what I can tell. I tried ifconfig e1000g3000 plumb (before the dladm create-vlan, of course) and it said, "Could not open DLPI link". I assume that the PPA-hack interface syntax was removed when the vanity naming was introduced. Do you have any idea if this is true? Does this mean it's impossible to use tagged VLANs on a Solaris 11 host with VirtualBox?

Changed 3 years ago by rlaager

comment:3 Changed 3 years ago by ramshankar

When a VLAN interface is detected the syslog should receive a message like:

vboxflt: e1000g30000 detected as VLAN interface with VID=3000

Does your syslog (/var/adm/messages) contain this line?

And yes, afaik PPA-hack was removed with the introduction of vanity names but that doesn't matter if you can create/plumb it with ifconfig or dladm as VBox's vboxflt driver resorts to detecting a VLAN based only on the PPA number.

comment:4 Changed 3 years ago by ramshankar

  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use