VirtualBox

Ticket #8779 (new defect)

Opened 3 years ago

Last modified 3 years ago

USB-Disk not showing up in Windows 7 Guest on Ubuntu 10.10 64bit

Reported by: webmicsch Owned by:
Priority: major Component: USB
Version: VirtualBox 4.0.6 Keywords: usb hdd disk linux windows
Cc: Guest type: Windows
Host type: Linux

Description

After the upgrade from 4.0.4 to 4.0.6 via Ubuntu's aptitude I can't access USB-Disks anymore, I tried it with two disks (3,5" and 2,5").

The mouse and keyboard wich are also connceted via USB work without problems, so do my USB-Stick and my iPhone. Only the USB-HDDs want show up in the Windows Guest.

When I connect the USB-Disks to the System everything looks okay, drivers got installed and Windows 7 tolds that the device is proper installed and ready for use. But when I open the Windows-Explorer there are no disk at all. The USB-Disk even shows up in the Device-Manager.

When I try to have a look in the Diskmanager-MMC the MMC opens but doesen't show the disks and the USB-Activity Icon in Virtualbox is not flashing but stays on the whole time.

The Diskmanerger-MMC stays grey until I disconnect the disk from the Guest via the USB-Icon or unplug the disk, then I see for a second the now disconnected USB-Disk and the System Disk. Then the USB-disk is gone and there is only the system disk to see.

There are no errors in the log file, as far as I can tell.

The right Extension Pack and Guest Additions are also installed.

A did an '/etc/init.d/vboxdrv setup' and rebooted the hostsystem, but that didn't help either.

Log and screenshot are attached.

Best regards
Michael

Attachments

Windows 7-2011-04-24-15-54-00.log Download (59.7 KB) - added by webmicsch 3 years ago.
Log
Windows 7 [Running] - Oracle VM VirtualBox.jpeg Download (237.3 KB) - added by webmicsch 3 years ago.
screenshot

Change History

Changed 3 years ago by webmicsch

Log

Changed 3 years ago by webmicsch

screenshot

comment:1 Changed 3 years ago by frank

Is the current user member of the vboxusers group?

comment:2 Changed 3 years ago by webmicsch

Yes, the current user is in the vboxusers group. Sorry, I forgot to tell you.

comment:3 Changed 3 years ago by SteveCGElliott

Is /etc/udev/rules.d/10-vboxdrv.rules present? VirtualBox installation some times fails to install it?

See  http://www.virtualbox.org/ticket/9273

Steve

comment:4 Changed 3 years ago by Darknight7

Windows XP guest here on gentoo 64bit. Virtualbox 4.1.2 Usb storage doesn't work, an usb webcam does. I see no errors whatsoever in the logs, I have placed the udev rules file too but it doesn't make a difference. Should I reboot the host to properly test it? Unfortunately I can't remember when (version) the problem started.

comment:5 Changed 3 years ago by Darknight7

Update: reboot did not fix the problem. The usb webcam isn't working anymore.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use