VirtualBox

Ticket #8771 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Command-Q not passed to OS X Server Guest

Reported by: mackyle Owned by:
Priority: major Component: GUI
Version: VirtualBox 4.0.6 Keywords:
Cc: Guest type: OSX Server
Host type: Mac OS X

Description

The VirtualBox VM GUI intercepts Command-H, Command-Option-H and Command-Q on the "VirtualBox VM" menu as shortcuts for Hide, Hide Others and Quit.

This means that in an OS X Server guest, pressing Command-Q asks if you want to quit the virtual machine even when the keyboard and mouse are captured by the VM. Other command keys are passed through to the virtual machine as they should be when the keyboard and mouse are captured.

Since Command-Q is a highly used keyboard combination on OS X Server it's very inconvenient that it's not passed into the guest properly.

A VirtualBox GUI option to remove the Command key equivalents from the "VirtualBox VM" menu so they can be passed into the guest would be nice (and not just for Mac OS X Server guests although the problem is probably most annoying with OS X Server guests). Or alternatively change them to be (Host+...) like the other VirtualBox VM menus already are.

Change History

comment:1 Changed 3 years ago by frank

Duplicate of #4208.

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use