VirtualBox

Ticket #8764 (new defect)

Opened 3 years ago

Last modified 3 years ago

Regression: VirtualBox and VM configuration broken if VM folder exists

Reported by: ralf Owned by:
Priority: critical Component: other
Version: VirtualBox 4.0.6 Keywords:
Cc: Guest type: other
Host type: Linux

Description

I just updated VirtualBox to version 4.0.6 through the Ubuntu 10.10 64bit repository you provide. The application is totally broken since then: It started with the configuration window not offering the list of categories at the left. The same happened when I tried to open a VM configuration. I then purged the VirtualBox configuration, which made the config work again - until I changed the VM folder to where I put my VMs. If I then restarted VirtualBox, the old state came back. I then tried to instead create a folder with the name VirtualBox suggested "(VirtualBox VMs" or similar), same effect. Some more attempts showed that, if the VM folder exists during VirtualBox start, everything breaks. Which of course makes it rather impossible to do anything. I could not find any log file or console output. VirtualBox also did not correctly re-add the VMs in the VM folder if I put them into the folder they were in - not sure how I am supposed to start them again. Yes, I did re-boot my whole system, to no avail.

I attached a screenshot of how the configuration window looks like.

Attachments

panel1.png Download (44.5 KB) - added by ralf 3 years ago.
broken config window

Change History

Changed 3 years ago by ralf

broken config window

comment:1 Changed 3 years ago by ralf

Interesting: If, after starting VirtualBox, I open the "import Appliance" assistant, cancel it immediately, and then open the global settings, they work fine. No idea what's going on...

Also, I managed to re-import my VMs, and they seem to work - though I sometimes have to use that appliance assistant trick to get their configuration window working.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use