VirtualBox

Ticket #8763 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Restore to snapshot crashes VM and leaves it inaccessible in VMM

Reported by: marshals Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.6 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

I installed 4.0.6, ga, rebooted, shutdown, saved snapshot, booted. I played around in the VM, before deciding to just throw away current state and restore to snapshot via clicking on the top-right close window button. The VM window went black and eventually win7 reported it as having crashed. Unfortunately win7 deleted the minidump when I oked through its popup.

In the VMM, the VM is now shown as inaccessible. Under Details, it suggests to "inspect the error message shown below", but there isn't one. Refresh does not change that.

Host is win7 64b, guest is ubuntu 10.10 32b.

Attachments

VBox.log Download (73.7 KB) - added by marshals 3 years ago.
log
Ubuntu10.10.vbox Download (25.3 KB) - added by marshals 3 years ago.
vmd
Logs.zip Download (56.4 KB) - added by jackyyaplt 3 years ago.
Containing the crash log
Windows Event.txt Download (947 bytes) - added by jackyyaplt 3 years ago.
Windows Event in XML

Change History

Changed 3 years ago by marshals

log

Changed 3 years ago by marshals

vmd

comment:1 Changed 3 years ago by marshals

Happily, when I restarted the VMM, the VM is no longer shown as inaccessible and appears to be normal (I can boot it etc). I could not reproduce the above crash, but if I do I'll be smarter about capturing the minidump. I guess the ticket priority can be reduced...

comment:2 Changed 3 years ago by jackyyaplt

This happened to me too. I am running Win7x64 Host and Win7x64 guest. After I shutdown the guest, and followed by restoring the snapshot, Windows popup a message stating that VB has crash, then VBox displayed as inaccessible.

But after delete the listing and re-adding it, it is able to restart.

Changed 3 years ago by jackyyaplt

Containing the crash log

Changed 3 years ago by jackyyaplt

Windows Event in XML

comment:3 Changed 3 years ago by jackyyaplt

Just another note on the above: After re-adding, I am then able to restore the snapshot and restart...

comment:4 Changed 3 years ago by jackyyaplt

I encountered another situation that also has the inaccessibility problem, which I believe could be due to the same reason. The following is the step to replicate this situation:

  • Ensure that you have 1 VB Machine listed in Virtual Box Manager.
  • Exit Virtual Box Manager.
  • Make a copy of your existing VB Machine and give it a different directory name.
  • Run Virtual Box Manager and remove the earlier VM Machine from the list.
  • Immediate, go to Add a new VB Machine (the one that you have manually copied).

You should get an error stating some inaccessibility, due to some IDs.

Regards, Jacky

comment:5 Changed 3 years ago by frank

Please could you check if you still experience this problem with VBox 4.0.8? We fixed a related bug.

comment:6 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

The final fix should be in VBox 4.1.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use