VirtualBox

Ticket #8744 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

linux kernel >2.6.32 grinds to a halt after a while

Reported by: yrro Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

I have found that booting into any kernel later than 2.6.32 will result in the VM hanging after a period of time (this can be as short as 15 minutes or a long as a couple of hours).

When this occurs the symptoms are that the keyboard may no longer be used to type into gnome-terminal, though I can still type into other programs. Attempting to log out or reboot the machine via the GNOME gui has no effect. As this occurs, more and more programs stop responding, until the only way out is a hard reboot.

This is 100% reproducible after booting into 2.6.38. I think I saw it with 2.6.37 before I upgraded to 2.6.38 though I am less sure. 2.6.32 works fine.

Attachments

wintermute-2011-04-17-22-20-13.log Download (58.2 KB) - added by yrro 3 years ago.
virtualbox log
ttyS0t Download (75.5 KB) - added by yrro 3 years ago.
linux kernel log messages

Change History

Changed 3 years ago by yrro

virtualbox log

comment:1 Changed 3 years ago by yrro

In the above bug I reset the VM at 1:05:57. Sadly there doesn't appear to be anything useful in the log, nor is there anything useful logged by the kernel.

comment:2 Changed 3 years ago by frank

Could you also attach the output of "dmesg" from the guest? I would prefer if you could boot your guest kernel with the following kernel parameters attached:

ignore_loglevel apic=debug console=ttyS0

Then make sure to enable the 1st COM port for that VM and select "file" as mode. Then wait until your guest halts. Then attach the resulting file to this ticket. I hope the guest kernel writes something useful to the log when this happens ...

Changed 3 years ago by yrro

linux kernel log messages

comment:3 Changed 3 years ago by yrro

Unfortunately the kernel doesn't appear to log anything useful. :(

comment:4 Changed 3 years ago by yrro

In case this is relevant, I've observed this problem with 4.0.8 with two different CPUs: a Core i7 920 (running Debian) and a core i5 950 (running Fedora 15).

comment:5 Changed 3 years ago by yrro

I've found that reducing the number of CPUs in my VMs to 1 has worked around this problem. I have left the IO APIC support enabled.

comment:6 Changed 3 years ago by yrro

Also present with Linux 2.6.39

comment:7 Changed 3 years ago by yrro

I have not seen this since upgrading to VirtualBox 4.1.0, on Linux 2.6.39.

I now run VirtualBox 4.1.2 and Linux 3.0.0 and everything is working fine.

comment:8 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback! Closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use