VirtualBox

Ticket #8728 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

in Linux guest, Subversion can't create symbolic link in shared folder from Windows host

Reported by: kenyee Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: other
Host type: other

Description

svn: E000071: Can't create symbolic link '/media/sf_OpenVPN/somefile.tmp': Protocol error

The Linux guest is Debian Squeeze running Subversion 1.7 (latest trunk build) The Windows host running Virtualbox is running Vista

When checking out a subversion repository into a shared folder, if the repository has any symbolic links checked in, you'll get this error. The shared folder isn't handling this case properly.

Attachments

debtest_6x64-2011-04-15-08-23-27.log Download (50.9 KB) - added by kenyee 3 years ago.

Change History

Changed 3 years ago by kenyee

comment:1 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Closing as duplicate of #818. Symbolic links for Windows hosts is already implemented. However, there are strange permission issues: There is a special permission required to create symbolic links on Windows.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use