VirtualBox

Ticket #8714 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

VB 4.0.2/4.0.4 dual monitor mouse problems

Reported by: rolandyoung Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.4 Keywords: mouse dual monitor 4.0
Cc: Guest type: Linux
Host type: Windows

Description

When using VB 4.0.2 or vb 4.0.4 on Windows 7 (64bit) or XP (32bit) dual monitor setups the mouse becomes unusable when the guest screen is on the 2nd monitor. The guest mouse area becomes horizontaly restricted and the pointer incorrectly returns to the host (as if right ctrl key was pressed) when moved beyond the boundary. These boundaries change when the mouse is moved quickly. My guest OS is Tinycore. The mouse behaves correctly when the guest window is dragged back to the 1st monitor. This problem does not occur with VB 3.2.12 and earlier releases. I am not using guest additions.

Change History

comment:1 Changed 3 years ago by grhebert

I have exactly the same problem since 4.x, works fine with 3.2.12. My host: WinXp 32-bit and Windows 7 32-bit, guest: QNX wihtout addition, Fedora 14 with mouse integration disabled.

But it works fine with guest "Fedora 14" with mouse integration.

comment:2 Changed 3 years ago by fiebig

I can confirm this behavior for version 4.0.6 on a Windows 7 32-bit host, but didn't have a problem before when using 4.0.4.

comment:3 Changed 3 years ago by fiebig

Ticket #8668 seems to describe the same problem. Should be merged.

comment:4 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Correct, duplicate of #8668.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use