VirtualBox

Ticket #8712 (closed defect: invalid)

Opened 3 years ago

Last modified 3 years ago

Running network in bridged mode crashes Virtual Box kernel module

Reported by: thilo.ginkel Owned by:
Priority: critical Component: other
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: other
Host type: Linux

Description (last modified by klaus) (diff)

When attempting to start a virtual machine on a Linux host, the Virtual Box kernel module crashes:

[11239.326347] general protection fault: 0000 [#1] SMP 
[11239.326351] last sysfs file: /sys/devices/system/cpu/cpu3/online
[11239.326353] CPU 0 
[11239.326355] Modules linked in: vboxnetadp vboxnetflt vboxdrv
 autofs4 parport_pc ppdev binfmt_misc nfsd microcode exportfs nfs
 lockd fscache nfs_acl auth_rpcgss sunrpc snd_usb_audio
 snd_usbmidi_lib coretemp nvidia(P) snd_hda_codec_realtek
 snd_emu10k1_synth snd_emux_synth snd_seq_virmidi snd_seq_midi_emul
 snd_hda_intel snd_emu10k1 snd_hda_codec snd_seq_midi
 snd_seq_midi_event snd_ac97_codec snd_seq ac97_bus snd_rawmidi
 snd_pcm uvcvideo snd_timer videodev psmouse snd_util_mem
 emu10k1_gp v4l2_compat_ioctl32 snd_seq_device serio_raw gameport
 snd_hwdep asus_atk0110 snd pata_marvell atl1e soundcore lp
 snd_page_alloc parport aes_x86_64 aes_generic xts gf128mul
 dm_crypt multipath linear raid0 raid1 usbhid hid ahci libahci
[11239.326393] 
[11239.326395] Pid: 8374, comm: VirtualBox Tainted: P            2.6.38-7-generic #35-Ubuntu System manufacturer P5QL PRO/P5QL PRO
[11239.326400] RIP: 0010:[<ffffffffa0fc27c1>]  [<ffffffffa0fc27c1>] vboxNetFltLinuxNotifierCallback+0x361/0x490 [vboxnetflt]
[11239.326407] RSP: 0018:ffff8800bffc1b08  EFLAGS: 00010293
[11239.326408] RAX: ffff8800bfcb4800 RBX: ffff8800bfcb59f0 RCX: ffff88021e531000
[11239.326410] RDX: ffff8801665d5b00 RSI: 0000000000000000 RDI: ffff8800bfcb5000
[11239.326412] RBP: ffff8800bffc1b88 R08: 0000000000000000 R09: ffff8800bfcb5000
[11239.326413] R10: 0000000000500000 R11: 0000000000000000 R12: ffff8800bfcb58c0
[11239.326415] R13: ffff88021e531000 R14: ffff8800bfcb5810 R15: ffff8800bffc1b48
[11239.326417] FS:  00007fc874d15700(0000) GS:ffff8800cfc00000(0000) knlGS:0000000000000000
[11239.326419] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[11239.326421] CR2: 00007fc870367008 CR3: 00000000bfee0000 CR4: 00000000000426f0
[11239.326423] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[11239.326425] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
[11239.326427] Process VirtualBox (pid: 8374, threadinfo ffff8800bffc0000, task ffff8800cb094440)
[11239.326428] Stack:
[11239.326430]  ffff8800bffc1b58 0000000000000246 ffffffffa0deff5c 0000000000000040
[11239.326433]  ffffffffa0deff5c ffff8800bfcb58ba 0000000000000028 ffff88021e531000
[11239.326437]  0000000000000282 0000000000000000 ffff8800bffc1b78 ffffffff81cf40f8
[11239.326440] Call Trace:
[11239.326457]  [<ffffffffa0deff5c>] ? rtR0MemAllocEx+0x7c/0x120 [vboxdrv]
[11239.326464]  [<ffffffffa0deff5c>] ? rtR0MemAllocEx+0x7c/0x120 [vboxdrv]
[11239.326469]  [<ffffffff814ccb99>] register_netdevice_notifier+0xa9/0x1d0
[11239.326473]  [<ffffffffa0fc1bc3>] vboxNetFltOsInitInstance+0x33/0x100 [vboxnetflt]
[11239.326476]  [<ffffffffa0fc3da0>] vboxNetFltFactoryCreateAndConnect+0x2c0/0x370 [vboxnetflt]
[11239.326484]  [<ffffffffa0deff5c>] ? rtR0MemAllocEx+0x7c/0x120 [vboxdrv]
[11239.326491]  [<ffffffffa0deff5c>] ? rtR0MemAllocEx+0x7c/0x120 [vboxdrv]
[11239.326500]  [<ffffffffa0deff5c>] ? rtR0MemAllocEx+0x7c/0x120 [vboxdrv]
[11239.326507]  [<ffffffffa0dea669>] ? supdrvIOCtl+0x269/0x27e0 [vboxdrv]
[11239.326513]  [<ffffffffa0deff5c>] ? rtR0MemAllocEx+0x7c/0x120 [vboxdrv]
[11239.326519]  [<ffffffffa0de6461>] ? VBoxDrvLinuxIOCtl+0x121/0x1e0 [vboxdrv]
[11239.326524]  [<ffffffff811751cf>] ? do_vfs_ioctl+0x8f/0x360
[11239.326526]  [<ffffffff81175531>] ? sys_ioctl+0x91/0xa0
[11239.326530]  [<ffffffff8100c002>] ? system_call_fastpath+0x16/0x1b
[11239.326531] Code: c7 c6 00 60 fc a0 4c 89 c7 e8 8c b9 52 e0 48 85 c0 0f 84 ec fd ff ff 83 3d 6c 39 00 00 02 0f 84 df fd ff ff 48 8b 15 b7 3b 00 00 <65> ff 02 44 8b 05 dd 55 ae e0 45 85 c0 0f 85 c9 00 00 00 48 8b 
[11239.326557] RIP  [<ffffffffa0fc27c1>] vboxNetFltLinuxNotifierCallback+0x361/0x490 [vboxnetflt]
[11239.326560]  RSP <ffff8800bffc1b08>
[11239.326563] ---[ end trace e492b7f42952d85e ]---
Linux andromeda 2.6.38-7-generic #35-Ubuntu SMP Tue Mar 15 21:33:06 UTC 2011 x86_64 GNU/Linux

Virtual Box crashes before the guest has entered its boot loader, so I assume that the exact OS version attempted to run inside the guest is not of importance.

The crash negatively affects the overall system stability, i.e. some kind of network I/O is no longer possible after the crash happened and the only way to rescue the system is MagicSysRq.

This seems to be the same issue as reported in  http://forum.virtualbox.org/viewtopic.php?f=7&t=38391&p=172249&hilit=vboxNetFltOsInitInstance&sid=42372fd048a1fc99ae19e8f77e9b0951#p172249.

The bug can be easily reproduced, so I'll be glad to test any fix candidates.

Attachments

VBox.log.1 Download (37.3 KB) - added by thilo.ginkel 3 years ago.
VBox.log

Change History

Changed 3 years ago by thilo.ginkel

VBox.log

comment:1 Changed 3 years ago by frank

So the host is Ubuntu Natty, correct?

comment:2 Changed 3 years ago by thilo.ginkel

Actually, it is Ubuntu Maverick with a Natty kernel.

comment:3 Changed 3 years ago by klaus

  • Description modified (diff)

comment:4 Changed 3 years ago by thilo.ginkel

When the crash happens, VirtualBox will not dump core on its own, but I was able to produce a core dump using the instructions (kill -4) at:  http://www.virtualbox.org/wiki/Core_dump

Please let me know, if you'd like me to send you a copy of this dump (~ 4 MB bzip2 compressed).

comment:5 Changed 3 years ago by frank

No thanks. We have to reproduce this issue.

comment:6 Changed 3 years ago by jukivili

Same bug with 2.6.38.3 on Ubuntu 10.10 when kernel compiled with gcc-4.5.

When kernel compiled with gcc-4.4, no crash.

comment:7 Changed 3 years ago by jukivili

Problem is with CONFIG_JUMP_LABEL. If kernel is compiled with gcc-4.5 (needed for CONFIG_JUMP_LABEL) and then module is compiled with gcc-4.4, trace points in module create havoc and result crash.

comment:8 Changed 3 years ago by frank

Moment. You have always use the same compiler for the Linux kernel and for the kernel modules. So either use gcc-4.4 or gcc-4.5 for the kernel and for the VBox modules. Actually this does not look like a VBox bug.

comment:9 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use