VirtualBox

Ticket #8677 (closed defect: fixed)

Opened 3 years ago

Last modified 11 months ago

Unable to create more than one snapshot on imported virtual appliance.

Reported by: nerakhon Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 4.0.4 Keywords: Snapshot, Virtual Appliance
Cc: Guest type: Solaris
Host type: Mac OS X

Description

Following import of virtual appliance with large number of VMDK drives (ZFS 7000 storage simulator), I tried to create snapshot before actual start to retain the virtual appliance state and then following configuration. In vbox 4.00 even creation of the first snapshot led to Solaris panicking due to not being able to read the zpool. Following update to 4.04, this happens upon second snapshot creation. It is completely reproducible and problem resolves if you remove the additional snapshot (4.00 1st, 4.04 second).

Change History

comment:1 Changed 11 months ago by aeichner

  • Status changed from new to closed
  • Resolution set to fixed

This was likely fixed long ago. There were quite a few fixes for VMDK images with snapshots and async I/O enabled. Please try again with a recent release of VirtualBox and reopen if necessary.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use