VirtualBox

Ticket #8668 (new defect)

Opened 3 years ago

Last modified 43 hours ago

Problems with mouse in guest, secondary monitor and disabled mouse integration

Reported by: zoltanf Owned by:
Priority: major Component: GUI
Version: VirtualBox 4.0.4 Keywords: mouse, disabled integration
Cc: Guest type: Linux
Host type: Windows

Description (last modified by michael) (diff)

On host, two monitors, configured in extended desktop mode (e.g. I have one desktop spanning across two monitors)

I have a guest OS that does not support guest addons (Linux based Android x86). The mouse integration is disabled in the guest settings. When I move the guest VM window to my secondary monitor, the mouse capturing functioniality starts acting realy weard (e.g. when I click inside the guest VM window to capture the mouse point, the mouse pointer appers on the host in the left/top position on the primary monitor, and the movement of the mouse cursor in the guest window stops and/or is erratic).

Everything works fine as long as my guest VM window is on the primary monitor.

Host OS is Windows 7 x64.

Change History

comment:1 Changed 3 years ago by zoltanf

How to replicate:

  • You need a windows OS host with 2 (or more) monitors, configured in extended desktop mode (e.g. desktop spanns across all display devices)
  • Create any guest VM (e.g. linux) and disable mouse integration features, don't install guest addons to the guest
  • Start the guest VM, and when boot up, move the VM window to the secondary monitor
  • Now click inside the guest VM window to capture the pointer, try to move the pointer in the guest VM

comment:2 Changed 3 years ago by net147

I can reproduce this bug on VirtualBox 4.1 with Windows 7 64-bit.

comment:3 Changed 3 years ago by muttzcuttz

I'd like to add that I have the same problem, host is Windows 7 x64. Problems have only started since the release of 4.0

ANY guest OS I use on my secondary monitor is totally unusuable. As soon as the host VM is powered on the VM window jumps to the bottom right of the secondary screen as soon as I try to move the VM window over, then after I try to move the VM Window I cannot. Other times the mouse tracking is way off, as if the mouse if in the guest but the cursor is pointing elsewhere.

I cannot use VirtualBox 4.x and am stuck on the last release of 3.2 as I have to have my VMs on my secondary monitor.

comment:4 Changed 3 years ago by rikky

Same problem here with Virtual Box 4.1.2 on Win 7 x64. The guest additions are installed, but without the xserver related stuff - I don't have a xserver installed.

vboxguest and vboxsf modules are loaded, but do not prevent the problem.

comment:5 Changed 2 years ago by ebonweaver

confirming this bug still exists in 4.1.6 on Win 7 64bit host using any Windows Guest. Unable to put guest window on second monitor without mouse freaking out. Must have guest window on primary display. It would be nice if a bug 7 months old received any sort of attention.

comment:6 Changed 14 months ago by DonGateley

Still true on 4.2.6 so I guess there is no interest among the developers to fix this. Sad, that.

comment:7 Changed 14 months ago by michael

  • Description modified (diff)

DonGateley, I understand if you are frustrated, but please see the notes on the main bug-tracker page<1> for an explanation of why some issues do not get fixed fast (or even at all), even if they seem important to you.

<1> https://www.virtualbox.org/wiki/Bugtracker

comment:8 Changed 14 months ago by michael

Since you have found a duplicate of this bug, rather than adding depressed comments to both you could try to decide which has the most information and add the information from the other ticket. That would save us time when we do find some to look at this issue.

comment:9 Changed 43 hours ago by billlater

Same problem here with Virtual Box 4.3.10 r93012 on Win 7 x64 host when install any Linux guest (Ubuntu,Debian Oracle). After install guest and installing guest additions the problem disappears......The problem appears again when the system starts and displays a login form. After enter to system the problem disappear again.

Last edited 42 hours ago by billlater (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use