VirtualBox

Ticket #8662 (closed defect: obsolete)

Opened 3 years ago

Last modified 3 months ago

weird PID in exception raised by mach.LockMachine

Reported by: vila Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

From a script displaying the currently running VMs, I get a weird traceback under unclear circumstances (say once every 1000 run or something):

vboxslave.py running Traceback (most recent call last):

File "/caviar3/babune/bin/vboxslave.py", line 505, in <module>

run()

File "/caviar3/babune/bin/vboxslave.py", line 496, in run

cmd.run()

File "/caviar3/babune/bin/vboxslave.py", line 463, in run

self._run_for_slave(name, self.running)

File "/caviar3/babune/bin/vboxslave.py", line 376, in _run_for_slave

slave = VboxSlave(name)

File "/caviar3/babune/bin/vboxslave.py", line 146, in init

self.session = self.open(permit_sharing)

File "/caviar3/babune/bin/vboxslave.py", line 149, in open

session = vbox_manager.openMachineSession(self.guest, permit_sharing)

File "/usr/lib/python2.6/dist-packages/vboxapi/init.py", line 561, in openMachineSession

mach.lockMachine(session, type)

File "<XPCOMObject method 'lockMachine'>", line 3, in lockMachine

xpcom.Exception: 0x80070005 (An unexpected process (PID=0x00003768) has tried to lock the machine 'freebsd-8.0-64bits', while only the process started by launchVMProcess (PID=0xFFFFFFFF) is allowed)

I have no idea where to look for that in the code, but PID=0xFFFFFFFF probably indicates a bug somewhere.

At the very least, it shouldn't generate such a backtrace but point the user to something more meaningful about the cause.

Change History

comment:1 Changed 3 years ago by vila

Host: Ubuntu maverick 10.10, various guests (Ubuntu, FreeBSD, gentoo, xp).

comment:2 Changed 3 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use