VirtualBox

Ticket #8660 (closed defect: duplicate)

Opened 3 years ago

Last modified 5 months ago

Virtual machine aborts on resume (VMCPU_FF_INTERRUPT_PIC)

Reported by: Aslo Owned by:
Priority: major Component: VMM
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

Since a couple of days ago, my Windows XP virtual guest (under a Ubuntu 10.04 64bit host) would not resume anymore after suspending, and instead it displays "Aborted" after trying to resume.

My virtual machine is configured to use IO APIC and two virtual processors, full hardware virtualization (VT-x) and nested paging.

I'm attaching the log, which fails with this assertion:

00:00:03.119 !!Assertion Failed!! 00:00:03.119 Expression: !VMCPU_FF_ISSET(pVCpu, VMCPU_FF_INTERRUPT_PIC) 00:00:03.119 Location : /home/vbox/vbox-4.0.4/src/VBox/VMM/VMMR3/PDM.cpp(862) int pdmR3LoadExec(VM*, SSMHANDLE*, uint32_t, uint32_t)

Attachments

VBox.log Download (56.4 KB) - added by Aslo 3 years ago.
VBox.log with the error
VBox.log.aborted Download (56.4 KB) - added by Aslo 3 years ago.
Another log which shows the same problem
WinXP-2011-04-01-08-42-12.log Download (52.1 KB) - added by pscholz 3 years ago.
Another Vbox log from a different environment
XP-2012-10-26-08-27-14.log Download (53.1 KB) - added by xiaq 18 months ago.
Yet another log. The VM settings contain no USB filters.
VBox.log.1 Download (60.0 KB) - added by CaptainDave 18 months ago.
Crash log of XP machine

Change History

Changed 3 years ago by Aslo

VBox.log with the error

Changed 3 years ago by Aslo

Another log which shows the same problem

comment:1 Changed 3 years ago by Aslo

Apparently, this is related to USB filters. I had recently added a couple of filters to automatically associate some devices with the VM. I have the USB 2.0 EHCI controller enabled.

If I remove the filters, I can reliably suspend and resume the virtual machine without errors.
If I put the filters back (or any other USB filter for that), resuming after suspend aborts.

Well, at least I have a workaround for this problem, that is, don't set up any USB filter.

Changed 3 years ago by pscholz

Another Vbox log from a different environment

comment:2 Changed 3 years ago by pscholz

I had the same problem with a WinXP Vbox on OpenSuse 11.4 64bit OS. Log file is attached above, hope it helps to track it down.

Thanks to Aslo for the workaround.

comment:3 Changed 22 months ago by matt12345

Hi I ran into this bug as well with Virtualbox 4.1.12 in Ubuntu 12.04 resuming a WinXP VM. Removing the usb filters solves the crash but has made Virtualbox less usable.

Error in the log:

00:00:02.110 !!Assertion Failed!! 00:00:02.110 Expression: !VMCPU_FF_ISSET(pVCpu, VMCPU_FF_INTERRUPT_PIC) 00:00:02.110 Location : /home/vbox/vbox-4.1.16/src/VBox/VMM/VMMR3/PDM.cpp(881) int pdmR3LoadExec(PVM, PSSMHANDLE, uint32_t, uint32_t)

comment:4 Changed 18 months ago by dedo

Same problem here, log file attached. Linux Mint 12 i386, Virtualbox 4.2.0 r80737. Using a USB filter for the keyboard to send Ctrl-Alt-Del at login time, as inserting it doesn't work from the menu, nor using Host-Del.

Edit: I am unable to attach the log file, the Submit button does nothing.

Last edited 18 months ago by dedo (previous) (diff)

comment:5 Changed 18 months ago by frank

  • Description modified (diff)

There is no submit button, you probably mean the 'Add Attachment' button. Did you compress your logfile?

comment:6 Changed 18 months ago by xiaq

I'm experiencing the same problem. However, I have no USB filters in the setting, so the workaround doesn't apply for me.

Saving / restore had worked for me before. The problem only popped up recently, quite likely due to version upgrade.

Changed 18 months ago by xiaq

Yet another log. The VM settings contain no USB filters.

Changed 18 months ago by CaptainDave

Crash log of XP machine

comment:7 Changed 16 months ago by frank

  • Summary changed from Virtual machine aborts on resume to Virtual machine aborts on resume (VMCPU_FF_INTERRUPT_PIC)

comment:8 Changed 16 months ago by CaptainDave

I've realized that this bug only rears its head for me when I use spectrwm (formerly scrotwm). If I use XFCE or awesome, all works as it should. I haven't the faintest why the VMM would care about a window manager on the host, but it seems to do exactly that.

Anyone else out there with similar cases?

comment:9 Changed 16 months ago by CaptainDave

Upon further examination, it's not just spectrwm. Fluxbox exhibits the same behavior.

The key seems to be exiting VirtualBox with the window close (delete, in X11 parlance) command key. For instance, in Fluxbox, if you hit Alt+F4, save and try to resume, the bug presents. If you close the VM with host + q or by clicking on the "X" in the corner of the window, however, it works as it should.

Last edited 16 months ago by CaptainDave (previous) (diff)

comment:10 Changed 16 months ago by cleeland

I don't think it's related to the window manager--at least not completely--because this just started happening to me on OS X 10.6 using 4.2.4 and XP.

00:00:06.207399 SSM: File header: Format 2.0, VirtualBox Version 4.2.4 r81684, 32-bit host, cbGCPhys=8, cbGCPtr=8
00:00:06.209169 SSM: Saved state info:
00:00:06.209196 SSM:   Build Type: release
00:00:06.209204 SSM:   Host OS: darwin.x86
00:00:06.224097 PCI:    PIIX3/0: register 60: 0b -> 05
00:00:06.224123 PCI:    PIIX3/0: register 61: 09 -> 0b
00:00:06.224132 PCI:    PIIX3/0: register 62: 0b -> 0a
00:00:06.224194 PCI: piix3ide/0: register 40: 00 -> 07
00:00:06.224203 PCI: piix3ide/0: register 41: 80 -> e3
00:00:06.224211 PCI: piix3ide/0: register 42: 00 -> 03
00:00:06.224219 PCI: piix3ide/0: register 43: 80 -> e3
00:00:06.224228 PCI:      vga/0:  8-bit field INTERRUPT_LINE: 9 -> b
00:00:06.224237 PCI:      vga/0: 16-bit field COMMAND: 3 -> 7
00:00:06.225137 PCI:    pcnet/0:  8-bit field LATENCY_TIMER: 0 -> 60 - !READ ONLY!
00:00:06.225148 PCI:    pcnet/0:  8-bit field INTERRUPT_LINE: b -> a
00:00:06.225182 PCI:   VMMDev/0: 16-bit field COMMAND: 3 -> 7
00:00:06.225236 PCI:  ichac97/0:  8-bit field INTERRUPT_LINE: b -> 5
00:00:06.225246 PCI:  ichac97/0: 16-bit field COMMAND: 1 -> 7
00:00:06.225258 PCI: usb-ohci/0:  8-bit field INTERRUPT_LINE: 9 -> b
00:00:06.225267 PCI: usb-ohci/0: 16-bit field COMMAND: 2 -> 7
00:00:06.225302 PCI:     acpi/0: 16-bit field COMMAND: 1 -> 7
00:00:06.225313 PCI:    pcnet/1:  8-bit field LATENCY_TIMER: 0 -> 60 - !READ ONLY!
00:00:06.225350 PCI: usb-ehci/0:  8-bit field INTERRUPT_LINE: b -> a
00:00:06.225360 PCI: usb-ehci/0: 16-bit field COMMAND: 2 -> 7
00:00:09.855338 TM: cTSCTicksPerSecond=0x6f41dd08 (1 866 587 400) fTSCVirtualized=true  fTSCUseRealTSC=false (state load)
00:00:09.876200 PIT: mode=2 count=0x2ead (11949) - 99.85 Hz (ch=0) (restore)
00:00:09.876246 RTC: stopped the periodic timer (restore)
00:00:09.876306 HGCM: restoring [VBoxSharedFolders]
00:00:09.876387 HGCM: restoring [VBoxGuestControlSvc]
00:00:09.876531 HGCM: restoring [VBoxGuestPropSvc]
00:00:09.877191 HGCM: restoring [VBoxDragAndDropSvc]
00:00:09.877209 HGCM: restoring [VBoxSharedClipboard]
00:00:09.877474 Guest Additions information report: additionsVersion = 0x00010004, osType = 0x00033000
00:00:09.879320 Audio: set_record_source ars=0 als=0 (not implemented)
00:00:09.886705 
00:00:09.886708 !!Assertion Failed!!
00:00:09.886709 Expression: !VMCPU_FF_ISSET(pVCpu, VMCPU_FF_INTERRUPT_PIC)
00:00:09.886711 Location  : /Users/vbox/tinderbox/4.2-mac-rel/src/VBox/VMM/VMMR3/PDM.cpp(902) int pdmR3LoadExec(VM*, SSMHANDLE*, uint32_t, uint32_t)

comment:11 Changed 16 months ago by CaptainDave

I've created a new ticket (#11289) that goes into slightly more detail as to the apparent causes of the bug. The two should probably be merged.

comment:12 Changed 5 months ago by frank

Removed the unrelated cross-link.

comment:13 Changed 5 months ago by danf84

Same problem! Reproduceable.

Hold any key within the guest, e.g. Left Shift, then click "X" to close the VirtualBox window. At this point, the key is still registered as "down" or "pressed" within the guest, and you're facing the "Paused" VirtualBox window. If you Save State, the Guest won't resume. Can we please fix it? :P

comment:14 Changed 5 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #11289.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use