VirtualBox

Ticket #866 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

Crash Guru Meditation -2304 (VERR_REM_TOO_MANY_TRAPS)

Reported by: samuel herzog Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.2 Keywords: crash windows xp 2304
Cc: Guest type: other
Host type: other

Description

Virtual Box 1.5.2 Host-System xubuntu 7.10 Guest-System WinXP

I have created a copy of my reall windows labtop and would like to run it as a guest on xubuntu.

I can start windows in "safemode" but if I start it in "normalmode" virtualbox crashes while showning the windows-start-screen.

Attachments

winlabtop-2007-11-06-15-48-24.log Download (118.8 KB) - added by samuel herzog 6 years ago.
VBox-openSUSE10.3-server_process.log Download (107.2 KB) - added by bernd 6 years ago.
VirtualBox log file that shows the Guru Mediation crash 2304 for a network intensive server process

Change History

Changed 6 years ago by samuel herzog

comment:1 Changed 6 years ago by frank

Ok, the Guru meditation is a bug of VirtualBox but did you consider  http://www.virtualbox.org/wiki/Migrate_Windows as well?

comment:2 Changed 6 years ago by samuel herzog

Thank you for the hint about Mirgrate to Windows.

agp440.sys is not on my virtual system disk. So this can not be the problem.

I started the system in safe mode and ran MergeIDE. Then I rebooted to normal mode but still the same problem. Started in safe mode again. Disabled some un-needed windows services. Then I rebooted to normal mode but still the same problem. Started in safe mode again. Removed some hardware entries which remained from the original physical installation. (e.g synapsys mouse and soundblaster stuff) Then I rebooted to normal mode but still the same problem.

About the HAL stuff I was not able to change that by using the windows recovery. If I boot from windows xp-cd and choose option R for recovery, I always end up in the dos-console. I search the virtual disk and found only hal.dll on it.

comment:3 Changed 6 years ago by sandervl73

  • Priority changed from blocker to major

comment:4 Changed 6 years ago by bernd

I've got the same Guru Meditation crash with VirtualBox 1.5.2. Both my host and my guest system are openSUSE 10.3. The guest has been installed from DVD within the VirtualBox, so no migration happened. It VM ran only one network intensive server process, no client software. The crash happened after about 10 hours of correct operation at a time when the machine ran unattended. I'll attach the log file.

Changed 6 years ago by bernd

VirtualBox log file that shows the Guru Mediation crash 2304 for a network intensive server process

comment:5 Changed 6 years ago by ckujau

I'm getting the same error with vbox-1.6. Host kernel is vanilla 2.6.25.1 (debian/sid), guest kernel would be the xen-3.0.3-1-i386-pae hypervisor trying to boot linux-image-2.6.18-6-xen-686 (debian/etch).

I've tried with  NAT and with no network configured at all. The error kicks in during bootup, so I'm not able to start the guest. PAE has been enabled for this guest with VBoxManage.

comment:6 Changed 6 years ago by samuel herzog

I solved this problem, by logging into windows in protected mode, then uninstalling all hardware-specific stuff and also the virus scanner.

After that I booted in windows xp in normal mode and did a re-install of the virus scanner.

Since then my old laptop is running inside virtualbox on my new labtop with PCLinuxOS as host system.

comment:7 follow-up: ↓ 8 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Ok, so Samuel's problem is solved. Regarding the other one (bernd), please create a new defect and add your information there if you can reproduce it with 1.6.0.

ckujau: it doesn't really surprise me the xen linux kernel doesn't work. If you have a CPU with VT-x, then try to enable hardware virtualization.

comment:8 in reply to: ↑ 7 ; follow-up: ↓ 9 Changed 6 years ago by ckujau

ckujau: it doesn't really surprise me the xen linux kernel doesn't work.

Why's that?

If you have a CPU with VT-x, then try to enable hardware virtualization.

Well, I would - if I had such a CPU. I was under the impression VT-x was optional and Virtualbox would run w/o it.

comment:9 in reply to: ↑ 8 Changed 6 years ago by sandervl73

Replying to ckujau:

ckujau: it doesn't really surprise me the xen linux kernel doesn't work.

Why's that?

Because it's hard to virtualize virtualization software.

If you have a CPU with VT-x, then try to enable hardware virtualization.

Well, I would - if I had such a CPU. I was under the impression VT-x was optional and Virtualbox would run w/o it.

It is, but we don't claim to run everything perfectly.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use