VirtualBox

Ticket #8629 (closed defect: fixed)

Opened 3 years ago

Last modified 20 months ago

Win7 x64 guest stalls, pauses under Vbox 4.04

Reported by: thePiet Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.0.4 Keywords: win7 x64, stalls, pauses, linux
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

As on  http://forums.virtualbox.org/viewtopic.php?f=2&p=180448:

Experiencing the following very frustrating behavior.

New VM recently created in vbox 4.04. Guest = Win7 Pro x64, host = Ubuntu 10.10 amd64, latest kernel, all updates applied. Host hardware is a Dell T3500 with quad core Xeon with HT and 6GB RAM (plenty of horsepower). Guest Additions installed. VM has 2GB RAM, 128 MB video, 2 CPUs. 2D acceleration enabled. 3D acceleration not enabled. Note that host storage is an ext4 filesystem, so Vbox requires Host I/O caching be enabled for all VM's due to known Linux kernel bug.

Behavior: every 30 secs or so, depending on user activity in the guest, Win7 freezes/stalls for about 15 secs, then resumes. Have a WinXP x64 SP3 VM running for last 2 years on Vbox version 3.x thru 4.04 and it runs perfectly...and fast. Also have an Ubuntu 10.04 guest that runs perfectly as well.

Have scoured this forum for answers. Some similar issues found but not this one. I have tried everything including the following: 2D acceleration on/off, 3D acceleration on/off (installed in Safe Mode), more RAM allocated, less video memory, dropped VM to 1 CPU, raised VM to 4 CPUs, no guest additions, re-install guest additions, download latest Windows 7 drivers, and many other VM settings toggled on/off or changed one at a time to isolate impact. Nothing eliminates the stalling. The only mitigating factor I have found is if I disable Audio in the VM, the stalling is less frequent but not eliminated. (VM audio is PulseAudio on host, Intel HD Audio on Guest.)

In the Win7 guest, I have turned on/off the visual performance settings (in Computer properties), chosen a non-Aero theme, disabled all power management props. Nothing corrects the freezing/stalling.

Could this be a Vbox 4.04 bug or a problem with the latest Guest Additions? It is understandable for this guest to run a little slower, but the freezing every minute or so is not normal.

I'm experiencing this issue too. Ubuntu 10.10 X64 fully updated, Virtualbox 4.04 and WIndows 7 X64 SP1 running of plenty-of-horsepower hardware. Tried re-installing the guest-additions without any luck.

Attachments

Windows 7-2011-03-24-21-20-52.log Download (51.9 KB) - added by thePiet 3 years ago.
Windows 7-2011-05-17-17-35-07.log Download (56.7 KB) - added by thePiet 3 years ago.
VBox 4.0.8 suffering issue
VBox_stalling_ICH9_AC97Audio.log Download (66.8 KB) - added by wacher 3 years ago.
issue
VBox_disabled_audio.log Download (65.5 KB) - added by wacher 3 years ago.
Sound test with DISABLED AUDIO option
VBox_null_audio.log Download (66.5 KB) - added by wacher 3 years ago.
Sound test with NULL AUDIO
dmesg_after_issue.log Download (49.6 KB) - added by thePiet 3 years ago.
dmesg after suffering the issue
VBox_2d3d_disabled.log Download (61.9 KB) - added by wacher 3 years ago.
Disabled video acceleration.
CPUHISTORY_2011-07-15_225908.jpg Download (189.6 KB) - added by wacher 3 years ago.
CPU usage of Virtualbox.exe
8629.zip Download (137.6 KB) - added by wacher 3 years ago.
I upload some new log and CPU history. I don't reopen the ticket, because I use beta version of Virtualbox not a stable one.
vbox_log_and_cpu_r73009.zip Download (139.7 KB) - added by wacher 3 years ago.
CPU usage of Virtualbox.exe, VBox.log
4.1.6r74713_stalled_2011-11-11_191916.png Download (13.3 KB) - added by wacher 2 years ago.
Not better

Change History

Changed 3 years ago by thePiet

comment:1 Changed 3 years ago by wacher

Here is a partial solution (*):

If I set chipset to PIIX3 then everything is OK. If I set chipset to ICH9 then the systems stalls.

(*) I don't know if it is a universal solution, but this is totally reproducable for me, I tried several times.

comment:2 Changed 3 years ago by wacher

+1 info: this is not Linux specific problem, I have WinXP host.

comment:3 Changed 3 years ago by frank

Can you check if  this test build fixes your problem? There was a bug in the HPET emulation which could be relevant.

comment:4 Changed 3 years ago by thePiet

Unfortunately, the test build does not fix the issue for me.

comment:5 Changed 3 years ago by frank

Thanks for testing. Does switching the chipset for that VM from ich9 to piix3 change anything?

comment:6 Changed 3 years ago by harmscon

+1 for switching to PIIX3 storage controller, from SATA AHCI

Host: Debian Lenny amd64 + VB 3.2.12 Guest: Win7 64bit

I tried removing VB guest additions but guest continued to freeze. Changing the Storage controller and the system has yet to freeze (2 hours and counting - previously wouldn't get past 20minutes).

The problem wasn't easy to replicate, but did appear to happen more frequently when multi-tasking, especially involving windows explorer. There was never any vbox.log entries to indicate any issues.

I'd also like to note that audio playback is now substantially improved. Previously the driver would fail to load (with and without guest additions). Now audio is available immediately from log in and without lag and jumps.

comment:7 Changed 3 years ago by frank

Actually I asked to switch the chipset of the mainboard from ICH9 to PIIX3, not the chipset of the storage controller! See VM settings / System / Motherboard. But if switching the storage controller from SATA to PIIX3/4 then this problem is I/O-related.

comment:8 Changed 3 years ago by thePiet

Switching the mainboard chipset from ICH9 to PIIX3 "fixes" the issue for me, using the test build.

comment:9 Changed 3 years ago by frank

thePiet, could you now use the PIIX3 and enable the HPET manually? Does the problem re-appear?

comment:10 Changed 3 years ago by thePiet

I've enabled HPET manually by a VBoxManage modifyvm <vm> --hpet on and indeed, the problem re-appeared.

comment:11 Changed 3 years ago by wacher

4.0.6: the problem still exists.

comment:12 Changed 3 years ago by wacher

Maybe #8707 and this ticket are related to each other?

comment:13 Changed 3 years ago by wacher

The problem is still exists in r71573.

comment:14 Changed 3 years ago by frank

thePiet, could you test  this build from #8707?

comment:15 Changed 3 years ago by thePiet

Frank, I'm sorry but I'm only able to test on Linux hosts here.

comment:16 Changed 3 years ago by frank

Sure, my fault :) Could you test  this build?

comment:17 Changed 3 years ago by thePiet

Unfortunately, the issue isn't completely solved using the test build. By completely I mean that it takes longer for the unwanted behaviour to occur; and that the duration of the "hangs" is shorter.

To be sure I've reinstalled the guest additions (if that has something to do with it) and I was able to reproduce the issue after several reboots of the guest (Win7 X64).

comment:18 Changed 3 years ago by dlee

I'm having the same issues with the latest build 4.0.7r71683 for Mac host. My Windows 7 64bit guest stalls every few minutes. I think it might have something to do with process activity since it mostly stalls whenever I do an action (click link, open new tab, etc.) with IE9.

I'm using ICH9 chipset, I'll report back if using PIIX3 fixes this.

comment:19 Changed 3 years ago by wacher

I tested 4.0.8 release, and the problem still exists.

comment:20 Changed 3 years ago by frank

wacher, please attach a VBox.log file of a VBox 4.0.8 session.

Changed 3 years ago by thePiet

VBox 4.0.8 suffering issue

Changed 3 years ago by wacher

issue

comment:21 Changed 3 years ago by wacher

Hilltop had a great idea and observation, I can justify him with a small test.

I start the VM, I stare at the clock for several minutes but nothing happen. I launch the Thunderbird, that make some noise at startup and right, the clock stalling. I use Intel HD Audio as well as he do (but this is indifferent, I tried this test with AC'97 and disabled sound too. The results are same).

The point is that everything is ok until the first few sound. (I played simple WAV file for testing too, this is not something Thunderbird specific issue :))

Maybe this is only an aspect of the problem, but it's worth some investigation, I think.

comment:22 Changed 3 years ago by frank

Yes, definitely. Can you test if you can reproduce these stalls with

  1. sound disabled
  2. sound enabled but with NUL backend?

Changed 3 years ago by wacher

Sound test with DISABLED AUDIO option

Changed 3 years ago by wacher

Sound test with NULL AUDIO

comment:23 Changed 3 years ago by wacher

Unfortunately none of them helped me. (I don't understand why stalling the VM with "disabled audio", but it stalled) Symptom is the same: 30 sec go, 12 sec no go. (30+12=42 very similar to HPET problem, but I already mentioned this)

comment:24 Changed 3 years ago by frank

Could you also attach the output of 'dmesg' from the host after there was a pause in the guest? And to rule out anything, could you also try to boot with 2D disabled and see if that changes anything?

Changed 3 years ago by thePiet

dmesg after suffering the issue

comment:25 Changed 3 years ago by thePiet

Regarding the last line in my dmesg:  http://forums.virtualbox.org/viewtopic.php?f=7&p=187097 . Seems that line has nothing to do with VirtualBox.

Changed 3 years ago by wacher

Disabled video acceleration.

comment:26 Changed 3 years ago by wacher

Has someone checked this issue with 4.0.10? It crossed my mind after I downgraded back to 4.0.8

comment:27 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if you still experience these issues with VBox 4.0.10.

comment:28 Changed 3 years ago by wacher

He will I believe :(

Unofficial comment (because I use 4.1 beta 3, not a stable release): Something is much worse than before.

See CPUHISTORY.jpg (I has just browsed the internet, nothing heavy thing.) (Intel Centrino 2)

Changed 3 years ago by wacher

CPU usage of Virtualbox.exe

Changed 3 years ago by wacher

I upload some new log and CPU history. I don't reopen the ticket, because I use beta version of Virtualbox not a stable one.

comment:29 Changed 3 years ago by wacher

8629.zip contains two log. One for ICH9 chipset and one for PIIX3 chipset.

comment:30 Changed 3 years ago by wacher

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:31 Changed 3 years ago by wacher

Here is my "official" 4.1.0 r73009 log and cpu history graph. The problem is still relevant and maybe worse than before when VM stalled for 12 sec only.

Changed 3 years ago by wacher

CPU usage of Virtualbox.exe, VBox.log

comment:32 Changed 3 years ago by zashone

This is a really serious bug that has been disturbing us for a long time , i had to switch my main dev win vm from win 7 to xp . Strange thing is that Vista is not affected by this problem , really hope to see a correction in 4.1.2

Regards

comment:33 Changed 3 years ago by wacher

You can use Windows 7 as guest OS, just simple set the chipset to PIIX3 (Settings->System->Chipset)

comment:34 Changed 3 years ago by harmscon

I also have this problem on Mac OS X 10.6.8 host running VirtualBox version 4.1.0 and Windows 7 guest. Windows 7 does won't boot if I change the Chipset to PIIX3 :-(

comment:35 Changed 3 years ago by zashone

Hi in my case changing the chipset does not help at all

comment:36 Changed 3 years ago by DHughes

I have the same problem with VB 4.1.0 running on a 4 CPU SuSE 11.4 host and windows guest systems with 2 CPUs defined I see the following:

On a Windows 7 guest every time I start Firefox the system freezes and one of the host systems cpus will go to 100% for 2.3 minutes. This was most noticeable after a recent Firefox upgrade, but is not limited to Firefox -- I get similar behavior in IE, while running other applications, and during system shutdown - just not as often as in Firefox. The system clock also stops updating -- when the system starts responding again the quest clock will be two minutes behind the host clock. If I open a performance monitor screen the graph will stop updating for two minutes and then continue with no jumps in the time markers at the bottom.

I have seem posts in the Mozilla forums of similar behavior with no concrete solutions.

Based on a post in the forums about multiple guest cpus and high utilization rates, I switched the guest to 1 cpu and the problem seemed to clear up. Changing to the PIIX3 chipset also seemed to work.

I first noticed this behavior after upgrading from VB version 3.

comment:37 Changed 3 years ago by frank

DHughes, so if you are using multiple CPUs but switch the chipset to PIIX3 it works as well?

comment:38 Changed 3 years ago by DHughes

Correct ICH9 and 1 cpu or PIIX3 and 2 cpus

comment:39 Changed 3 years ago by DHughes

As additional data points.

I was applying patches today. Working on a Windows 7 guest system with one CPU and PIIX3 chipset took several orders of magnitude longer than any of the XP systems. There were several long stretches of time ( maybe 30 minutes ) with 100% CPU and some network activity. The XP system took around 10 minutes the Windows 7 system over 3 hrs. However, this is different from what I reported above in that the guest clock continued to update. A similar non-virtualized Windows 7 system took around 15 minutes.

In addition, trying to open a network drive containing several hundred sub-folders times out after about 3 minutes, the same drive opens without delay on an XP system or non-virtualized Windows 7 system.

comment:40 Changed 2 years ago by frank

Still relevant with VBox 4.1.6? If so, does it change anything if you change the chipset type from ICH9 to PIIX3?

comment:41 Changed 2 years ago by wacher

Yes, I tested, I found similar symptoms.

Changed 2 years ago by wacher

Not better

comment:42 Changed 2 years ago by jjinnsoft

I can confirm this issue as well on VirtualBox 4.1.6, at least on Windows 7 host. Apparently the problem is still not fixed. To reproduce:

  1. I upgraded to vbox 4.1.6 on Windows 7 host.
  2. Set up new Windows 7 64-bit guest with these settings:
  3. System/Motherboard: ICH9 chipset, enable IO APIC is checked, EFI is not enabled, absolute pointing device not enabled, 1280 MB base memory
  4. System/Processor: 8 processors (host is hyper-threaded quad-core i7 processor), 100% execution cap, PAE/NX is enabled
  5. System/Acceleration: both VT-x and nested paging are enabled
  6. Display/Video: 128 MB video memory (host is GeForce GTS 250), 1 monitor, 2D & 3D acceleration both enabled
  7. Storage: 1 IDE controller with ICH6 type & host I/O cache enabled. One CD/DVD drive attached as IDE primary master. 1 SATA controller, AHCI type, 1 port, host I/O cache disabled. 250 GB VDI image attached.
  8. Audio: Intel HD Audio controller is enabled
  9. Network: one adapter enabled; emulated adapter type is Intel PRO/1000 MT Desktop (82540EM); it is a bridged adapter attachment
  10. Serial Ports: No serial ports (default)
  11. USB: USB & USB 2.0 controllers both enabled
  12. Install clean copy of Windows 7 64-bit RTM.
  13. Install vbox guest tools; the WDDM driver is selected to enable Aero Glass.
  14. Aero Glass is turned on.
  15. Browse through Control Panel. After a minute or two of clicking around, the guest temporarily hangs, but eventually comes back to life. As others have noted, the mouse pointer still changes when I move the mouse over parts of the UI. I can even click on things during the hang and it apparently does things. For example, I can click the Start button while hung, and the search box in the start menu (which I can't see yet) displays an I-beam cursor as expected. However, the screen does not update for a period of maybe 30 seconds (I haven't timed it exact).
  16. Here's the really weird bit: if I run Windows Media Player and play one of the songs that comes with Windows 7, I can browse Control Panel while the music plays and it won't hang. After closing Windows Media Player, the system will again hang randomly when browsing through Control Panel.

In my attempts to resolve this, I tried uninstalling the guest tools. This changed the behavior of the hang, but did not solve it completely. After doing this, it appeared that the entire guest OS would temporarily hang (whereas before it seemed like it still ran, but didn't update the screen), and my mouse cursor no longer updated to new cursors (I could still move it, but did not change to resize cursor on window borders, etc.).

The solution, as others have noted, was to change from ICH9 to PIIX controller. This seems to have resolved the issue for me, as it did with others.

comment:43 Changed 23 months ago by ...don

Although not a definitive test, I switched the system mentioned above back to the ICH9 chipset under VB 4.1.16, and the system freeze did not occur during 30 minutes of testing.

comment:44 Changed 23 months ago by wacher

I've made a quick test, unfortunately I wasn't so lucky as you :( (VM stalled for cca. two minutes, VM ran for cca. two minutes)

Version 1, edited 23 months ago by wacher (previous) (next) (diff)

comment:45 Changed 22 months ago by kbuehler

I had an lenoveo T61/p with debian lenny host and several guests (ubuntu, WINXPSP3, WIN7SP1)running even oracle 11.2g database (64Bit) on WIN7/64. Ran VirtualBox 4.1.16. I never experienced any problems.

My notebook crashed last week (probably CPU) and I got me a brandnew lenovo T520 4243-5HG running an i7-2670QM quad core CPU.

Installed Ubuntu 12.04 LTS with all updates, VirtualBox 4.1.16 and moved my VMs. From that moment on I experienced exactly the problems described by jjinnsoft above.

  • Stalling guest for random amount of time, mostly with 1 host CPU at 100% but sometimes also without any special load on host.
  • It seemed to me also, that starting FireFox triggered freezing. But there were other triggers as well. Nothing systematic.
  • Guessed that migrating an existing installation and changing from IDE to SATA host controller might cause this problem. So accusing WIN7, since my Ubuntu and XP guests run without problems.
  • Installed a brandnew WIN7_64 Enterprise ed. from scratch: 4CPU's, ICH9, 2G mem, 20G disk. VT/x enabled, hyperthreading enabled in BIOS. IO APIC enabled, absolute pointing dev enabled. EFI disabled. VT-x and nested paging enabled. IDE-controller for CD/DVD. SATA AHCI for disk: Behavior is even worse. WIN7 does not even shut down normally. It hangs forever on the shutdown screen with one CPU at 100%. Switching to PIIX3 after installation did not help.
  • Reinstalled WIN7_64 with System/Motherboard set to PIIX3 initially. Does not change anything. WIN7_64 freezes on shutdownscreen on reboot after installation of guest- additions. Guest additions were installed rigth after finishing installation wiht first reboot into OS. System monitor shows random context switches every 10 to 12 sec. though. Guest stays frozen.
  • Initially also tried disabling hyperthreading and assigning only one CPU to the guest-os. Nothing worked.

Any chance to get this fixed in near future or shall I fix my T61 and revert back to it?

comment:46 Changed 22 months ago by frank

  • Description modified (diff)

kbuehler, I would like to see a VBox.log file of at least one VM on your new laptop which shows these guest stalls.

comment:47 Changed 21 months ago by Calf

I have been having this same issue for weeks on my Vbox client with Win7. It would most often occur when using Quickbooks and selecting the date/time but happened regularly in other scenarios as well - in such a scenario the mouse moved but nothing else worked - then after waiting a minute or two it would all seem to work again fine. I found this fix and indeed it does work well - finally my VM is very functional.

comment:48 Changed 21 months ago by Calf

Also I should point out that I have Win7 x32, not x64

comment:49 Changed 20 months ago by frank

Any improvement with VBox 4.1.20?

comment:50 Changed 20 months ago by Ilshavoh

4.1.20 solved the problem for me. In my case the stutter started exactly every 300 seconds and lasted 145 seconds.

comment:51 Changed 20 months ago by wacher

4.2 RC2 seems to be OK.

comment:52 Changed 20 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Thanks, so I will close this ticket. 4.1.20 contains the same fixes regarding to HPET like 4.2 RC2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use