VirtualBox

Ticket #861 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

FreeBSD sees network interfaces as 10Mbps

Reported by: vuori Owned by:
Priority: major Component: network
Version: VirtualBox 1.5.2 Keywords: freebsd slow network speed 10baseT
Cc: Guest type: BSD
Host type: other

Description

FreeBSD 5.5 and 6.2 both see the VirtualBox network interfaces as "10baseT/UTP". Attempting to change the media with ifconfig to 100baseTX or autoselect results in "invalid argument". The interface also acts as 10Mbps. It appears that the MII probe doesn't return all speeds:

  pcn0: <AMD PCnet/PCI 10/100BaseTX> port 0xc020-0xc03f mem 0xf0000000-0xf0000fff irq 11 at device 3.0 on pci0 
  pcn0: Chip ID 2625 (Am79C973)
  miibus0: <MII bus> on pcn0
  acphy0: <AC101 10/100 media interface> on miibus0
  acphy0:  10baseT

FreeBSD 6.3-BETA1 defaults to "none" for the media and seems to be unable to receive packets.

This is with host networking. Two Linux (Debian Etch) guests report 100Mbps for the interface. NetBSD 3.1 seems to have the same issue as FreeBSD 6.3, but I was unable to test it further due to other problems. Host is Debian Etch 4.0r1 with virtualbox.org .deb.

Change History

comment:1 Changed 6 years ago by Technologov

This bug is INVALID, because VirtualBox emulates 10Mbps Ethernet AMD PCnet LAN interface. Your Debian guests report incorrectly.

-Technologov. 05.Nov.2007.

comment:2 Changed 6 years ago by frank

Actually there are 10MBps and 100MBps versions of the PCNet card. Debian (and since VBox 1.5.2) Windows report 100MBps and this is what we want. Of course the speed the guest reports has nothing to do with the speed the guest can achieve by transferring bytes over the network.

comment:3 Changed 6 years ago by vuori

My bad, even though it reports 10Mbps the VM does indeed move data faster. The problem was with my test target, so this should probably be reprioritized to "cosmetic".

comment:4 Changed 6 years ago by miltondf

we have an application CPU reaches 85% and up once the network its utilize at its maximum. we're currently bridging the networkcards. We've also tested by plugging in (magic jack) which is a voice phone system onto the usb of the virtualbox and when it is being used the quality is horrible due to slowness within the virtual network. if we have it under the regular host it works fine. this we think is the cause of many slowness issues with sql, file server or whataver that people are mentioning about. we'd like to see if maybe we can increase the mb to 10 or 100, we try to run a ftp server to test the line and we only get up to 5mbps if we put a server on this it would be too slow to run properly.

comment:5 Changed 6 years ago by miltondf

we have an application CPU reaches 85% and up once the network its utilize at its maximum. we're currently bridging the networkcards. We've also tested by plugging in (magic jack) which is a voice phone system onto the usb of the virtualbox and when it is being used the quality is horrible due to slowness within the virtual network. if we have it under the regular host it works fine. this we think is the cause of many slowness issues with sql, file server or whataver that people are mentioning about. we'd like to see if maybe we can increase the mb to 10 or 100, we try to run a ftp server to test the line and we only get up to 5mbps if we put a server on this it would be too slow to run properly.

comment:6 Changed 6 years ago by frank

  • Component changed from other to network

comment:7 Changed 6 years ago by frank

  • Guest type changed from other to BSD

comment:8 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Obsolete. For FreeBSD use the E1000 emulation.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use