VirtualBox

Ticket #8595 (reopened defect)

Opened 3 years ago

Last modified 9 months ago

VBOX_E_OBJECT_NOT_FOUND error after closing Virtual Machine => Fixed in SVN

Reported by: john.doe Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 4.0.4 Keywords: VBOX_E_OBJECT_NOT_FOUND
Cc: Guest type: Windows
Host type: Windows

Description

Steps done:

  1. use Virtualbox manager to start a virtual machine
  2. so dome work using your virtual machine
  3. press the X to power off the machine and make sure that "restore to snapshot YY" is checked.
  4. close Virtualbox manager
  5. open Virtualbox manager again to start the machine again
  6. you are now presented with an error message telling you that the hard disk could not be found:

Could not find an open hard disk with UUID {guid_1}
Result Code: VBOX_E_OBJECT_NOT_FOUND (0x80BB0001)
Component: VirtualBox
Interface: IVirtualBox {guid_2}

The guid written to the .VirtualBox\VirtualBox.xml is not the same as the guid of the new snapshot .vid file (seems to me that it actually does not write to the file but keep the old guid, thereby creating a mismatch when it starts up again). The xml file for the machine seems to be correctly updated tho.

Furthermore this behavior does not always happen, but only sometimes (some rare issue when writing to disk maybe?).
The solution as of now to this problem is to replace the xml files and the snapshot folder with a backup so that the guid's are in sync again. Just editing the xml file does not work for some reason.

Operating System: Windows 7, 64Bit
Extensions installed: Oracle VM Virtual Box 4.0.4r70112

Attachments

VirtualBox.xml Download (4.9 KB) - added by mikegillan 3 years ago.
mikegillan's VirtualBox.xml file
Windows XP.xml Download (36.9 KB) - added by mikegillan 3 years ago.
mikegillan's VM xml file

Change History

comment:1 follow-up: ↓ 2 Changed 3 years ago by mikegillan

I have encountered the same issue but haven't used the "restore to snapshot YY" as described above - I simply shutdown the virtual machine and saved the present state.

Executing the VBoxManage showvminfo command gives the following output:

VBoxManage showvminfo {ab721b84-0b15-4cd9-943d-2c453c1097cc} --details
Name:            <inaccessible!>
UUID:            ab721b84-0b15-4cd9-943d-2c453c1097cc
Config file:     /home/mgillan/.VirtualBox/Machines/Windows XP/Windows XP.xml
Access error details:
VBoxManage: error: Could not find an open hard disk with UUID {626600ce-2cc4-4c67-87ae-dc147ff1e89e}
VBoxManage: error: Details: code VBOX_E_OBJECT_NOT_FOUND (0x80bb0001), component VirtualBox, interface IVirtualBox, callee 

However, the .vdi file with the specified UUID is clearly found in the Snapshots directory:

... (snip)
-rw------- 1 mgillan mgillan  925937664 2011-03-10 11:12 {626600ce-2cc4-4c67-87ae-dc147ff1e89e}.vdi
-rw------- 1 mgillan mgillan 2812322304 2010-10-02 15:36 {74919c44-70dc-40dd-873d-7815a13b2135}.vdi
... (snip)

comment:2 in reply to: ↑ 1 Changed 3 years ago by mikegillan

Replying to mikegillan: Sorry, forgot to include relevant system details: OS: Linux (Ubuntu 10.10 Maverick Meerkat 64-bit, kernel 2.6.35-28-generic, virtualbox-4.0 (4.0.4-70112~Ubuntu~maverick)

Changed 3 years ago by mikegillan

mikegillan's VirtualBox.xml file

Changed 3 years ago by mikegillan

mikegillan's VM xml file

comment:4 follow-up: ↓ 25 Changed 3 years ago by Skalek

OS: Windows 7 X64

Guests: XP and Windows 7

Ever since upgrading to 4.0.4, I am constantly getting these errors as well. For the most part I can get it back to work by fiddling with the XML files but its becoming a real PITA.

Could not find an open hard disk with UUID {003c8508-7c80-4631-bf19-eaef1708de1d}. Result Code: VBOX_E_OBJECT_NOT_FOUND (0x80BB0001) Component: VirtualBox Interface: IVirtualBox {d2de270c-1d4b-4c9e-843f-bbb9b47269ff}

When I look at my snapshots folder for the machine, this UUID does exist.

When I looked in my VirtualBox.XML file I did not find that UUID listed as a HardDisk, but did see a snapshot that does not exist:

<HardDisk uuid="{037e0c72-ff02-4d5d-b6ff-8c9884a81eaa}" location="F:/My Virtual Machines/VirtualBox/Windows XP Pro/Snapshots/{037e0c72-ff02-4d5d-b6ff-8c9884a81eaa}.vdi" format="VDI"/>

I changed that line to:

<HardDisk uuid="{003c8508-7c80-4631-bf19-eaef1708de1d}" location="F:/My Virtual Machines/VirtualBox/Windows XP Pro/Snapshots/{003c8508-7c80-4631-bf19-eaef1708de1d}.vdi" format="VDI"/>     

VirtualBox now starts properly.

It seems that it is putting the wrong UUID in the VirtualBox.XML, which is causing the error on startup. To fix this:

  1. Close VBox
  2. Edit VirtualBox.xml
  3. Find snapshot that does not exist
  4. Replace the UUIDs in that line with the ones that VBox is looking for.
  5. Start VBox

comment:5 Changed 3 years ago by hartnegg

Two more observations:

1: It doesn't make a difference if the machine was stopped with Ctrl-Q or by cleanly shutting it down.

2: The VDI, that is missing in VirtualBox.xml, seems to have a different internal UUID than what its filename suggests. Thus it's not possible to add it to VirtualBox.xml. This results in an error message regarding duplicate UUIDs. One must instead edit the xml of the affected machine, go to near the end and change the VDI there to another one from the same virtual machine.

comment:6 Changed 3 years ago by Skalek

This continues to happen almost every time I shutdown the virtualbox gui.

comment:7 Changed 3 years ago by Skalek

I should also say i just resolved this by not touching the machine XML file and instead just replacing the UUID that does not exist with the one its complaining about at startup.

comment:8 Changed 3 years ago by Skalek

How can we get a dev to look at this bug. It has become a constant issue every time I shutdown the vbox gui.

comment:9 Changed 3 years ago by tikitu

I've identified the point where things go wrong: restoring a snapshot from a changed current state puts the uuids in VirtualBox.xml and the machine's own xml config file out of synch.

I opened a ticket for the issue, with more details:  8648.

comment:10 Changed 3 years ago by frank

Then this is a duplicate of #8363 and the bug will be fixed in the next maintenance release. Do you want a test build? If so, please tell me which package you are currently using.

comment:11 Changed 3 years ago by Skalek

I would love a Windows test build if possible.

comment:12 Changed 3 years ago by frank

 Here is the link.

comment:13 Changed 3 years ago by tikitu

Thanks for the quick response, and apologies for the duplicate ticket. A test build would be great; I'm on Ubuntu 64-bit.

comment:14 Changed 3 years ago by frank

 Here is the 64-bit Maverick build.

comment:15 Changed 3 years ago by tikitu

Thanks again, and apologies for the second duplicate ticket (which I just found). Erm... if it's not too much trouble, would you have a Lucid 64-bit build?

comment:16 Changed 3 years ago by frank

 Here is the 64-bit Lucid build.

comment:17 Changed 3 years ago by tikitu

Thanks very much (so far no new dup's to apologise for...).

comment:18 Changed 3 years ago by Skalek

Thank you very much! It is greatly appreciated.

comment:19 Changed 3 years ago by orenagiv

Any chance for a Fedora 14 64bit RPM..?

comment:20 Changed 3 years ago by frank

 Here is the 64-bit Fedora 14 build.

comment:21 Changed 3 years ago by orenagiv

Updated the virtualbox.xml and installed the RPM - works like a charm! Many MANY thanks!!!

comment:22 Changed 3 years ago by frank

  • Summary changed from VBOX_E_OBJECT_NOT_FOUND error after closing Virtual Machine to VBOX_E_OBJECT_NOT_FOUND error after closing Virtual Machine => Fixed in SVN

comment:23 Changed 3 years ago by Dany

So, any idea when 4.0.5 gets released to the public? The (test-)link here to the Windows version is not working for me and I need it really urgent (OS Win7 x86, Guest XPSP2x86).

comment:24 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

VBox 4.0.6 is out and contains the fix.

comment:25 in reply to: ↑ 4 Changed 3 years ago by nemec

Replying to Skalek:

When I looked in my VirtualBox.XML file I did not find that UUID listed as a HardDisk, but did see a snapshot that does not exist:

I've got the same symptoms, but my trouble is that there are actually *many* such UUIDs in my VirtualBox.xml which are not in the snapshots directory, so I don't know which one to replace. See my post on  http://forums.virtualbox.org/viewtopic.php?f=6&t=40199&p=189555#p189555

Thanks!

comment:26 Changed 3 years ago by mast

  • Status changed from closed to reopened
  • Resolution fixed deleted

I noticed the same problem in 4.0.10 (or at least one that fits the original description very well). This is on an Ubuntu host, though.

comment:27 Changed 2 years ago by hartnegg

I keep getting this problem about once every two weeks. VirtualBox version 4.1.8 in Windows XP with SP3. Happens on all three PCs where I use VirtualBox. Each time it happens after going back to a previous snapshot or after merging two snapshots. Each time the xml file of the machine has a wrong ID in one of the last lines, that needs to be replaced by the latest ID in the main xml file, from the section of the affected machine. And each time a vdi-file with that ID does exist although it claims that it doesn't.

Please fix this, it's extremely annoying and it effectively stops me from using VirtualBox for anything else except private stuff, that's not too much important. I would love to use it on two servers as well, but that's completely unacceptable as long as this problem keeps popping up.

comment:28 Changed 2 years ago by neil

I am also getting this error (I'm commenting to get update mails).

  • VirtualBox 4.1.8r75467
  • Host: Win7-64
  • Guest: WinXP (32)

I get it every time I try to restore a snapshot, and delete the current state. Thanks

comment:29 Changed 2 years ago by psychedup

I got this error this morning for the first time.

Virtualbox 4.1.8r75467 Host: Windows 7-64 Guests: Gentoo Linux (64)

I wasn't doing anything with snapshots, I don't even have any snapshots saved. I have 2 VM's and was using them both yesterday. At the end of the day I shut both VM's down normally and closed VirtualBox before shutting down the Windows 7 host machine. This morning I went to fire up VirtualBox and I have this error message showing up for both VM's.

What I did to fix it was:

  1. Close out of VirtualBox
  2. Open the .vbox file for the VM in a text editor. Look for a section towards the end of the file labeled <Image uuid="[the UUID from the error message]"> and delete the whole <AttachedDevice> section around it.
  3. Reopen VirtualBox
  4. Open the Settings for the VM and reattach the hard disk file.

After that I was able to get the VM to start up again normally without losing any of my other settings.

I find it disturbing that this can happen for no apparent reason. It is quite upsetting to be told that you may have lost all the work you've done in a virtual machine, and a lot of users who aren't brave enough to dig into the config files would really be up a creek in this situation.

Last edited 2 years ago by frank (previous) (diff)

comment:30 Changed 9 months ago by wreckwriter

VirtualBox 4.2.16.R86992 Host Windows XP Pro SP3 Guest LinuxMint 15 (both 32 bit). No snapshots.

Been using Vbox with zero issues for weeks. Today suddenly get this error. First time I recreated the machine but second time I used the method posted above.

No idea why this would suddenly start happening, nothing was changed.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use