VirtualBox

Ticket #8553 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Going fullscreen switches desktops

Reported by: OxOOCOFFEE Owned by:
Priority: major Component: GUI
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

I installed vbox 4.0.4 on MacBook pro early 2011 Sandy Bridge 2.7GHz. There is a separate ticket #8549 for a different bug that contain log file. This problem is related to trying to move XP host to external monitor and going full screen. When entering full screen, vbox automatically goes to primary MacBook Pro screen. After a while I was able to figure out that I need to assign which screen I need to assign to. It was not so obvious until I switched to seamless mode that the were was option under View switch screen I need to assign it to. I was not able to see View option in windowed mode. Just wondering why I have to and if I really have to select from menu which screen I want vbox to be assign to. My natural expectation was just move host to screen that I want to go to full screen to and than enter full screen. I guess permanent screen preassigning is a good idea but it I do not do so I should be able to go to full screen in the screen which I am working with.

Change History

comment:1 Changed 3 years ago by OxOOCOFFEE

Also want to add that when I am running vbox on external monitor in full screen mac top application bar/menu is auto hiding on MBP. not too bad thing but little annoying since I have to click on MBP desktop to see it to check battery status/clock or anything else that is running

comment:2 Changed 3 years ago by OxOOCOFFEE

Also want to add that in version 4.0.6 in full screen there is a View that you can quickly switch which monitor you want to move vbox in full screen . Nice....

comment:3 Changed 3 years ago by OxOOCOFFEE

Running 4.0.7 and the problem still exists. External desktop is totally not usable.

comment:4 Changed 3 years ago by klaus

  • Status changed from new to closed
  • Resolution set to fixed

Confirmed fixed by 4.0.8. Probably another duplicate of #7606.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use