VirtualBox

Ticket #8549 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Very Bad Screen redraw problem on secondary monitor

Reported by: OxOOCOFFEE Owned by:
Priority: major Component: GUI
Version: VirtualBox 4.0.4 Keywords: Second monitor repaint
Cc: Guest type: Windows
Host type: Mac OS X

Description

I just got new Sandy Bridge MacBook Pro 13" 2.7. After installing fresh copy of Virtualbox 4.0.4 and setting up fresh copy of XP x32 with all latest updates as guest I installed vbox guest tools as last step. Running VBox on MacBook Pro itself seems fine. When I attach external monitor (mini port to DVI, Samsung SyncMaster PX2370 LED) and try to start XP guest it is starting fine on main MacBook Pro screen. Now when I try try to move the guest to external monitor I am seeing very bad repaint problems. Moving a mouse causes partial repaint of some controls in guest. If I leave XP running on external monitor and click anything on Mac book pro makes entire screen black. If I drag back XP guest to mac book screen it works fine( not restart required) I try to give more Video ram all the way to 128Mb and turning on and off 2d acceleration (never enabled 3D acceleration) but that did not change anything. I am attaching my log file. Please let me know if there is anything you might need from my machine.

Attachments

VBox.log Download (77.4 KB) - added by OxOOCOFFEE 3 years ago.
Log when running session on external monitor

Change History

Changed 3 years ago by OxOOCOFFEE

Log when running session on external monitor

comment:1 Changed 3 years ago by OxOOCOFFEE

I just updated to 10.6.7 and still the same problem

comment:2 Changed 3 years ago by ad1815

I have exactly the same problem, with bothh xp and ubuntu 10.10 as guest. vbox extensions are installed in both guests.

comment:3 Changed 3 years ago by OxOOCOFFEE

After reading Bug #8474 I started to think perhaps this problem is related to it. So I rebooted into 32bit mode (Hold button 2 and 3 when turning power on till logon screen) and second monitor started to work and no problems what so ever.

comment:4 Changed 3 years ago by OxOOCOFFEE

Little update. There seems to be little problem with screen updates (not sure if it is just related to latest MBP 2011 with Intel HD 3000 gfx card but some mac windows are having problem updating specifically when you use spaces and keep switching in and out. This is when you do not run vbox (I am on 4.0.6 now, mac 10.6.7). I am working with upper Apple care support on this. vbox in 32bit mode is running ok as I stated above. But perhaps since there seems to be two problems related to gfx they might be in some relevance. So I just wanted to make people aware.

comment:5 Changed 3 years ago by poetzsch

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #7606.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use