VirtualBox

Ticket #8544 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

USB broken in multi-cpu Windows guests on Mac OS X hosts

Reported by: omascia Owned by:
Priority: critical Component: USB
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

Any Windows 7 guests, 32 or 64 bits, on VirtualBox 4.0.0, 4.0.2, 4.0.4 (never used versions 3.x) running on Mac OS X 10.6 host (never used VB on other Mac OS X versions) fails mounting most of my USB devices (USB flash drives) when the guest has more than 1 cpu configured. Shutdown, bring cpu count to 1, boot, and it looks it succeeds all the times (that I tested). This is of course an unpractical work-around.

With one device, it even fails with 1 cpu (the device works fine with non virtualized Windows and with vmWare and parallels (previous experience on our production test machines). That device is a portable barcode scanner from Symbol (now Motorola), model MC3000. That device very strangely is reported by VirtualBox with a name in "Symbö" (note the strange unexpected and wrong accented character 'ö' instead of the pair of ascii characters "ol" at the end of the name. Due to that name string error, even the single CPU VMs can't correctly mount the device.

Extension Pack (PUEL) is, of course, installed. Should it be tried without?

Should it be tried without the guest extensions installed?

Change History

comment:1 follow-up: ↓ 5 Changed 3 years ago by rusky

I have the same issue with a Fujitsu ScanSnap S1500. Works okay with Parallels as Mac OS X host and Windows 7 as guest. Very annoying as need to run this device in Windows not on host. Have tried with and without USB filter and also tried with and without extension pack. Doesn't work in any combination. Running guest with 4 cpu's.

Error as follows:

Result Code: NS_ERROR_INVALID_ARG (0x80070057) Component: HostUSBDevice Interface: IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a} Callee: IConsole {515e8e8d-f932-4d8e-9f32-79a52aead882}

comment:2 Changed 3 years ago by Kemal.Soysal@…

I have the same issue with 4.0.8 neither an usb memory stick nor another usb mass storage device would be detected successfully in Win XP SP3 32Bit + uptodate patches.

comment:3 Changed 3 years ago by Kemal.Soysal@…

I tried at last to sudo

sudo /Applications/VirtualBox.app/Contents/MacOS/VirtualBox

I imported the virtual box created on my account, started it, and it works.

My suggestion was something like the user rights, how do I introduce a vboxusers group and a usbusers group on Mac OS X like it is approached on Ubuntu platform?

comment:4 Changed 3 years ago by Kemal.Soysal@…

Ok, there is a drawback :) a second external harddrive is not recognized like the first one before

comment:5 in reply to: ↑ 1 Changed 3 years ago by rusky

I found a work around for any storage USB device (eg, USB memory stick) or SD flash card. I mount the device to my host Mac OS X and then add it as an additional SATA storage device in VB. My Windows 7 guest then sees it as a hard drive instead of a USB removable device, after formatting the new drive in Windows. Not perfect but works okay if you are happy to re-start each time you want add/remove the device from the USB/card port. My original Fujitsu ScanSnap S1500 problem remains unresolved.

comment:6 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #7462.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use