VirtualBox

Ticket #8532 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

problem in 4.0.4 with VHD image - image will not boot => Fixed in SVN

Reported by: smipx013 Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 4.0.4 Keywords: 4.0.4 vhd "black screen" upgrade
Cc: Guest type: Windows
Host type: Windows

Description

I was on 3.2.12 and happlily running a VM with W2K3 which was originally created as a VHD with Virtual PC for Windows7. All was good. I then upgraded to 4.0.4 and now when I try to start the VM I just get a black screen. I do not get any disk activity at all. I tried all of the usual tweaking of the settings just in case 4.0.4 had a default setting that was different to 3.2.12 but nothing worked.

I then used CloneVDI to migrate the VHD file to a VDI file. Set all of the settings back to the way they were before I upgraded (i.e. virtualization, CPU's, IO APIC etc) and it booted first time - no problem. Just to be sure I detached the VDI and reattached the VHD and got the black screen again with no activity whatsoever on the disk.

I think there is an issue with the upgrade to 4.0.4 or a compatability issue with VHD that is not there in 3.x. Something gets screwed when its a VHD of a certain type.

Change History

comment:1 Changed 3 years ago by frank

Are there snapshots involved in your setup?

comment:2 Changed 3 years ago by smipx013

Hi,

No there are/were no snapshots. The VM is 2 x VHD disks that are both dynamically expanding.

I have reverted back to 3.2.12 now as I needed to work and I had some other issues with another VM and the VDI version of this one (a few crashes) and I will stick to 3.x for the time being.

If you need me to I can FTP the VHD files to you for further investigation but you will need to provide an FTP site as the two files total around 9Gb.

thanks Paul

comment:3 Changed 3 years ago by mvdriel

Same problem here. Workaround for this issues seems to be the normal procedure to compact a VHD (in Virtual PC):

  • defragment the hard disk in the guest OS
  • run the Precompactor in the guest OS (from Virtual Disk Precompactor ISO)
  • run the VPC2007 Virtual Disk Wizard to compact the .VHD from host OS

Probably a small corruption (or some fragmentation) in the VHD is causing the problem in Virtualbox.

comment:4 Changed 3 years ago by aeichner

Is it possible to upload the problematic VHD image? I'm not able to reproduce this issue here.

comment:5 Changed 3 years ago by frank

For uploading please use our public FTP server (ftp.virtualbox.org:/incoming). That directory is write-only for the public. After successful upload, please contact me via private e-mail at frank _dot_ mehnert _at_ oracle _dot_ com to tell me that you finished uploading and the file name. Thank you!

comment:6 Changed 3 years ago by mvdriel

An example of such a problematic VHD image is the Windows XP / IE6 version of the Internet Explorer Application Compatibility VPC Images from Microsoft:  Download link

comment:7 Changed 3 years ago by frank

  • Summary changed from problem in 4.0.4 with VHD image - image will not boot to problem in 4.0.4 with VHD image - image will not boot => Fixed in SVN

Thank you all for the report and thanks for the pointer! Finally we were able to reproduce the problem and found a bug. The bug will be fixed in the next maintenance release. In VBox 4.0 we introduce multi-sector writing from the BIOS code and this triggered an old bug in the VHD backend.

comment:8 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

VBox 4.1.4 contains the fix.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use