VirtualBox

Ticket #8514 (new defect)

Opened 3 years ago

Last modified 14 months ago

Virtualbox USB Error. Failed to attach Unknown Device on Win7 x64 Enterprise Host.

Reported by: swimmer70002 Owned by:
Priority: major Component: USB
Version: VirtualBox 4.0.4 Keywords: USB, Failed to attach unknown device, win7, x64, enterprise
Cc: Guest type: other
Host type: Windows

Description

This is in reference to this post:  http://forums.virtualbox.org/viewtopic.php?f=6&t=39753#p178233

No matter what version of Virtualbox I use, with 'Extension Pack' installed on v4.0.0+, I continuously get a 'Failed to attach the USB Device Unknown device' message when booting up any guest OS. I'm running Win7 x64 Enterprise and I tried 'Admin Mode' and 'Compatibility Mode'. Nada.

Change History

comment:1 follow-up: ↓ 2 Changed 3 years ago by hk.charles

I have the same issue on Windows 7 x64 Ultimate.

comment:2 in reply to: ↑ 1 Changed 3 years ago by hk.charles

Replying to hk.charles:

I have the same issue on Windows 7 x64 Ultimate.

And it works fine on Mac. So the issue should be Windows 7 (probably 64bit?) specific.

comment:3 Changed 3 years ago by et_tu_brute

I have the same issue on Windows Vista Ultimate x86.

comment:4 follow-up: ↓ 5 Changed 3 years ago by jh73

Same Unknown device error when trying to attach or detach a second USB mouse on Windows 7 Home Premium 64 bit (AMD Athlon) host with Linux Mint 10 guest.

The same VM had no USB problems after moving it to an early 2008 Mac Pro running Windows 7 Ultimate with Bootcamp. This machine is a dual Xeon E5462. There are also no problems on the (Windows 7 Ultimate/bootcamp) Mac Pro with an Ubuntu 10.1 Guest VM.

The "VirtualBox USB" controller appears in windows device manager on the Xeon Mac Pro after starting the VM, but it does not appear on the AMD machine.

Please advise if further details are needed.

comment:5 in reply to: ↑ 4 Changed 3 years ago by jh73

Replying to jh73:

Removed "UpperFilters" value from registry HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000} as descibed here:  http://forums.virtualbox.org/viewtopic.php?f=2&t=37326

This fixed the USB problems on Windows 7 Home Premium 64 bit (AMD).

comment:6 Changed 3 years ago by cpachmayr

I have the same issue on Windows 7 x64; previous versions of VirtualBox worked without problem.

comment:7 Changed 3 years ago by lithiumc

Problem seems to still exist in 4.0.6 and removing UpperFilters didn't seem to work either. Can anyone confirm?

comment:8 Changed 14 months ago by Obeco

I spent lots of time on this issue and now it works.

Host: Windows 8 64 bit Guest: Windows XP Virtualbox: 4.2.6

First I did what some post suggested (sorry couldn't find it) about editing the registry to remove key inside: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36fc9e60-c465-11cf-8056-444553540000}

And said how to manually add the Virtualbox USB drivers. The key didn't exist in my registry but I did follow the steps to manual install the Virtualbox USB driver. I think by right clicking the file VBoxUSB.inf inside the Virtualbox/drivers/USB/device folder, either that one or the driver (VBoxUSBMon.inf) inside the Virtualbox/drivers/USB/filter folder.

I have no idea if that helped.

However then I read a post that Virtualbox doesn't support USB 3 and suggesting plugging the devices to a USB 2 port. In my computer these are labeled as eSata.

Then I restarted Windows 8, opened up virtualbox and waited for the guest os to load, connected the USB devices. I was then able to attach them perfectly! I am using an old scanner and printer that have no drivers for Windows 8 so I use them in Windows XP as a guest OS and worked perfectly.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use