VirtualBox

Ticket #8509 (closed defect: wontfix)

Opened 3 years ago

Last modified 3 years ago

Virtualbox 4.0.4 Fedora 13 64 bit build failure

Reported by: maxeaves Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: other
Host type: other

Description

Hello Oracle,

I've tried downloading the latest version [a couple of times] of Version 4.0.4 for Fedora 13 [x86_64].

On installing [using RPM], the build comes up with the following error:

[root@maxslaptop Downloads]# rpm -Uvh VirtualBox-4.0-4.0.4_70112_fedora13-1.x86_64.rpm warning: VirtualBox-4.0-4.0.4_70112_fedora13-1.x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 98ab5139: NOKEY Preparing... ########################################### [100%] A copy of VirtualBox is currently running. Please close it and try again. Please note that it can take up to ten seconds for VirtualBox (in particular the VBoxSVC daemon) to finish running. error: %pre(VirtualBox-4.0-4.0.4_70112_fedora13-1.x86_64) scriptlet failed, exit status 1 error: install: %pre scriptlet failed (2), skipping VirtualBox-4.0-4.0.4_70112_fedora13-1

There seems to be a bug in the pre-install scripts.

Thanks

Max

Change History

comment:1 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

This is not a bug in the script but it seems that there is a VBoxSVC daemon running as written by the error message. There must be no open VBox GUI and there must be no running VBox VM. Then check if a process named 'VBoxSVC' is still running. Also no web services. If you there is an instance of VBoxSVC running anyway you can kill it.

comment:2 Changed 3 years ago by maxeaves

  • Status changed from closed to reopened
  • Resolution worksforme deleted

Frank,

This is different to 3.x.x series of Virtualbox, because you never needed to manually stop the VirtualBox services prior to upgrading. I didn't have a VM running, but certainly had the vboxsrv running.

You were right, however, because once I had manually stopped the vbox services, the installation was correct and worked and I am now running 4.0.4.

I noticed that in the installation; it does state "Stopping VirtualBox kernel modules [OK] " - is it possible for the installer to make sure that there are no Vbox services running at the time.

Thanks

Max

comment:3 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to wontfix

No, it is not possible to ensure this. There are a number of reasons why the VBoxSVC server could still be running, the web services is one reason, a running VM is another. As long as there is an active VBoxSVC we refuse to upgrade and we will not change this. Of course the installer could check every single reason but this is too much effort. Other users did heavily complain as we allowed this with older VBox versions.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use