VirtualBox

Ticket #8508 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Guest Additions 4.0.4 cause BSOD - IRQL_NOT_LESS_OR_EQUAL

Reported by: scoobieia Owned by:
Priority: critical Component: guest additions
Version: VirtualBox 4.0.4 Keywords: BSOD
Cc: Guest type: Windows
Host type: Windows

Description

Upgraded virtual box from 3.2.8 to 4.0.4. No problems. Then upgraded the guest additions to 4.0.4. Guest now gives BSOD - IRQL_NOT_LESS_OR_EQUAL - Stop 0A. Disabling the VT-x/AMD-V allows to boot into Windows, but causes a different stop when shutting down.

Host: Windows 7 64bit Home Premium Guest: Windows XP SP 3

All drivers etc are up to date.

No problems with 4.0.4 or guest additions with Ubuntu or Ubuntu Server64

Change History

comment:1 Changed 3 years ago by sunlover

Please install updated guest additions:

 http://www.virtualbox.org/download/testcase/VBoxGuestAdditions-r70281.iso

This build might fix the problem.

comment:2 Changed 3 years ago by scoobieia

unfortunately, it did not fix the problem :(

Other details that may be helpful - AMD Phenom II P920 Quad-Core 4.0 GB mem HP Pavilion dv7 laptop model dvr-4051nr

Also, using 4.0.4 with 3.2.8 guest additions works. Soon as I upgrade to 4.0.4 or the suggested r70281, I get the BSOD unless I disable the VT-x/AMD-V.

comment:3 Changed 3 years ago by scoobieia

Uninstalling Avira Antivir fixed the problem. Trying other anti-virus's now. Will report if another causes the same problem.

comment:4 Changed 3 years ago by sunlover

There is a newer build of the guest additions:

 http://www.virtualbox.org/download/testcase/VBoxGuestAdditions-r70411.iso

You could try it as well. There were a couple of fixes for possible guest crashes.

Thanks.

comment:5 Changed 3 years ago by jones.79

I had a similar problem: Vbox 4.0.4, WinXP guest, Ubuntu 10.04 host.

Windows crashed showing non-informative with installed guest additions 4.0.4. Booting in safe mode and uninstalling the guest additions removed the problem. The error was reproducible.

Installing the guest additions 70411 (4.0.5) removed the problem.

comment:6 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

So it appears that the problem is fixed as the fix is contained in VBox 4.0.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use