VirtualBox

Ticket #8472 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Cannot open a session on VM since 4.0.4 upgrade

Reported by: Celia Owned by:
Priority: critical Component: other
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

Ever since I upgraded to 4.0.4 earlier today, I have been getting the following error message:

Failed to open a session for the virtual machine Windows Vista. Failed to load VMMR0.r0 (VERR_SUPLIB_WORLD_WRITABLE). Unknown error creating VM (VERR_SUPLIB_WORLD_WRITABLE).

Here is the log:

00:00:00.800 VirtualBox 4.0.4 r70112 darwin.x86 (Feb 17 2011 17:33:47) release log 00:00:00.800 Log opened 2011-03-02T00:11:56.391830000Z 00:00:00.801 OS Product: Darwin 00:00:00.801 OS Release: 9.8.0 00:00:00.801 OS Version: Darwin Kernel Version 9.8.0: Wed Jul 15 16:55:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_I386 00:00:00.801 DMI Product Name: MacBook5,1 00:00:00.801 DMI Product Version: 1.0 00:00:00.801 Host RAM: 4096MB RAM, available: 2982MB 00:00:00.801 Executable: /Applications/VirtualBox.app/Contents/MacOS/../Resources/VirtualBoxVM.app/Contents/MacOS/VirtualBoxVM 00:00:00.801 Process ID: 301 00:00:00.801 Package type: DARWIN_32BITS_GENERIC 00:00:00.867 pdmR3LoadR0U: pszName="VMMR0.r0" rc=VERR_SUPLIB_WORLD_WRITABLE szErr="World writable: '/Applications'" 00:00:00.867 VMSetError: /Users/vbox/tinderbox/4.0-mac-rel/src/VBox/VMM/VMMR3/VM.cpp(579) int vmR3CreateU(UVM*, uint32_t, int (*)(VM*, void*), void*); rc=VERR_SUPLIB_WORLD_WRITABLE 00:00:00.867 VMSetError: Failed to load VMMR0.r0 00:00:00.867 VMSetError: /Users/vbox/tinderbox/4.0-mac-rel/src/VBox/VMM/VMMR3/VM.cpp(350) int VMR3Create(uint32_t, const VMM2USERMETHODS*, void (*)(VM*, void*, int, const char*, unsigned int, const char*, const char*, char*), void*, int (*)(VM*, void*), void*, VM); rc=VERR_SUPLIB_WORLD_WRITABLE 00:00:00.867 VMSetError: Unknown error creating VM 00:00:00.867 ERROR [COM]: aRC=NS_ERROR_FAILURE (0x80004005) aIID={515e8e8d-f932-4d8e-9f32-79a52aead882} aComponent={Console} aText={Failed to load VMMR0.r0 (VERR_SUPLIB_WORLD_WRITABLE). 00:00:00.867 Unknown error creating VM (VERR_SUPLIB_WORLD_WRITABLE)}, preserve=false 00:00:01.125 Power up failed (vrc=VERR_SUPLIB_WORLD_WRITABLE, rc=NS_ERROR_FAILURE (0X80004005))

I tried going into Disk Utility on my Mac and repairing permissions, then rebooting, as suggested on the Forum, but that has not helped. This is a huge problem for me as I rely on using Virtual Box to access some Windows programs on my mac.. Please advise. Thanks!!

Change History

comment:1 Changed 3 years ago by Celia

I'm really sorry!! I didn't see the part about not pasting log files.. Here is my message without the log. If I messed something up at your end, I'm sorry!

Ever since I upgraded to 4.0.4 earlier today, I have been getting the following error message:

Failed to open a session for the virtual machine Windows Vista. Failed to load VMMR0.r0 (VERR_SUPLIB_WORLD_WRITABLE). Unknown error creating VM (VERR_SUPLIB_WORLD_WRITABLE).

I tried going into Disk Utility on my Mac and repairing permissions, then rebooting, as suggested on the Forum, but that has not helped. This is a huge problem for me as I rely on using Virtual Box to access some Windows programs on my mac.. Please advise. Thanks!!

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

This is a duplicate of #8410. Please check the permissions of the /Applications directory -- post the output of /bin/ls -ld /Applications into #8410.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use