VirtualBox

Ticket #8452 (closed defect: fixed)

Opened 3 years ago

Last modified 11 months ago

Problems with storage on vbox "block corruption"

Reported by: bmohareb Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description (last modified by aeichner) (diff)

I have installed virtual box 4.0.0. I created Oracle Enterprise Linux 64bit virtual machine.

The problem is that whenever I copy a file from the internet or using ftp, or scp from another machine to the virtual image, the file seems to get corrupted, the checksum is always wrong for the file.

Tried several times to copy different types of files, and the problem is the same.

I also created 11gR2 Oracle database, and since I installed it, it reports corrupted blocks within the datafiles.

Attachments

VBox.log.1 Download (133.4 KB) - added by bmohareb 3 years ago.
vbox log file
FMW IDM 11.1.1.5.0 (OEL 5.6 64-bit)-2011-06-14-13-12-41.log Download (92.4 KB) - added by hbroeder 3 years ago.
FMW IDM 11.1.1.5.0 (OEL 5.6 64-bit)-2011-06-14-13-12-41.2.log Download (92.4 KB) - added by hbroeder 3 years ago.
FMW IDM 11.1.1.5.0 (OEL 5.6 64-bit)-2011-06-14-13-16-24.log Download (86.1 KB) - added by hbroeder 3 years ago.
FMW IDM 11.1.1.5.0 (OEL 5.6 64-bit)-2011-06-14-22-41-57.log Download (86.4 KB) - added by hbroeder 3 years ago.
FMW IDM 11.1.1.5.0 (OEL 5.6 64-bit)-2011-06-15-10-35-19.log Download (54.7 KB) - added by hbroeder 3 years ago.

Change History

comment:1 Changed 3 years ago by bmohareb

I have installed 4.0.4, and the problem still exists.

comment:2 Changed 3 years ago by frank

  • Cc beshoy.mohareb@… removed
  • Version changed from VirtualBox 4.0.0 to VirtualBox 4.0.4

Please attach a VBox.log file of such a VM session. I assume you copy the files from the network, correct? And where is the database installed, is that on the virtual disk or on any external disk?

comment:3 Changed 3 years ago by bmohareb

  1. I copy the files from the network using a bridged ethernet to the virtual machine.
  2. Database is installed on virtual disk.
  3. When I copy files from the network, I copy them from the network to the virtual disk.
  4. I have the vbox running on a windows host, which is running the linux guest. I connect from a different machine to the guest using ssh. I found the VBox.log on the windows host, hope this is the one you need.

comment:4 Changed 3 years ago by bmohareb

Typo:

  1. I copy the files from the network using a bridged ethernet to the virtual machine.

Should be:

  1. I copy the files from the network using a bridged ethernet.

Changed 3 years ago by bmohareb

vbox log file

comment:5 Changed 3 years ago by frank

Thanks for the logfile. Could it be that your images are already somehow corrupted? Did you do a disk consistency check within the guest? Furthermore, could you change the network interface to NAT and check if the checksum is correct?

comment:6 Changed 3 years ago by bmohareb

I have created those images from scratch, so they are not corrupted. The problem is that I do the same from different vmware guests and the issue is the same. It seems to be a bug. for the network interface, It is a requirement to make the this machine available on the LAN, so we made it bridged to take an IP address from the DHCP server on the LAN.

comment:7 Changed 3 years ago by xtensa

Confirm having the same problem. I am trying to instal Oracle DB. Files are downloaded to host machine, checksums are correct. After copying to the guest machine files are corrupted. Tried to copy using chared folder and scp. The result is the same. Checksum each time is different. Guest OD is OEL 5.5.

comment:8 Changed 3 years ago by higuita

Hi

Some problem... i'm copying the weblogic jar (wls1034_generic.jar) and it gave a corrupted md5. when i use rsync, i most of the time can copy the file and have the correct md5, but if it reboot the machine and the again check the md5 of the same file it gives a wrong md5 again

here is the host data: virtualbox 4.0.4 on debian squeeze x86_64 with the oracle virtual VM extension pack

here is the Guest data:

# lsb_release -a
LSB Version:    :core-4.0-amd64
                :core-4.0-ia32
                :core-4.0-noarch
                :graphics-4.0-amd64
                :graphics-4.0-ia32
                :graphics-4.0-noarch
                :printing-4.0-amd64
                :printing-4.0-ia32
                :printing-4.0-noarch
Distributor ID: EnterpriseEnterpriseServer
Description:    Enterprise Linux Enterprise Linux Server release 5.6 (Carthage)
Release:        5.6
Codename:       Carthage

# uname -a
Linux srv-app-pre2 2.6.18-238.el5 #1 SMP
  Tue Jan 4 15:41:11 EST 2011 x86_64 x86_64 x86_64 GNU/Linux

i have the VirtualBox additions installed (same version as the Virtualbox)

I manage to store one copy of the file with a correct md5 and tried to rsync it to another disk+partition and in the end the destination showed a bad md5, but the source still had the correct md5... of course, after reboot, both files had the wrong md5 (both different)

i tried to play with the "host io cache" but made no diffence... tried to add a new scsi controller - LSI - (system is still using the SATA one) and a new HD to test... the file copied fine, the md5sum is OK after the copy AND after reboot, so seems that the problem is in the SATA controller

comment:9 Changed 3 years ago by frank

We fixed a bug which could be related to your problems. Could you install  this test build and check if your problem is fixed?

comment:10 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.0.8.

comment:11 Changed 3 years ago by hbroeder

  • Status changed from closed to reopened
  • Resolution fixed deleted

The issue is still relevant with VBox 4.0.8 r71778 I have installed an Oracle database 11.2.0.1.0 on Guest OS Oracle Enterprise Linux 5.6 x86_64 with kernel 2.6.32-100.26.2.el5 Everything runs ok, but whenever I restart the VM image the database reports ORA-600 errors regarding block corruptions.

guest data:

lsb_release -a
LSB Version:    :core-4.0-amd64
                :core-4.0-ia32
                :core-4.0-noarch
                :graphics-4.0-amd64
                :graphics-4.0-ia32
                :graphics-4.0-noarch
                :printing-4.0-amd64
                :printing-4.0-ia32
                :printing-4.0-noarch
Distributor ID: EnterpriseEnterpriseServer
Description:    Enterprise Linux Enterprise Linux Server release 5.6 (Carthage)
Release:        5.6
Codename:       Carthage

uname -a
Linux iamsrvr.local 2.6.32-100.26.2.el5 #1 SMP
  Tue Jan 18 20:11:49 EST 2011 x86_64 x86_64 x86_64 GNU/Linux

I'll attach the VBox log files

Changed 3 years ago by hbroeder

Changed 3 years ago by hbroeder

Changed 3 years ago by hbroeder

Changed 3 years ago by hbroeder

comment:12 Changed 11 months ago by aeichner

  • Status changed from reopened to closed
  • Resolution set to fixed
  • Description modified (diff)

There were a few corruption fixes in later VirtualBox releases. Please test with a recent release and reopen if necessary.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use