VirtualBox

Ticket #845 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

Starting VirtualBox breaks host networking

Reported by: zorko Owned by:
Priority: major Component: network
Version: VirtualBox 1.5.2 Keywords: network vista usb
Cc: Guest type: other
Host type: Windows

Description

Just by starting VirtualBox, without running any virtual machine, my wireless network adapter stops working.

If I run ipconfig/all, everything looks exactly the same but the interface is no longer working.

I can work around it by resetting the interface with:

netsh interface set interface "Wireless Network Connection" disabled

followed by

netsh interface set interface "Wireless Network Connection" enabled

After this network connections will work form both the host and the guest.

I am running Windows Vista Home Premium as the host.

One thing perhaps worth mentioning is that although the wireless adapter is built-in in my notebook, it looks to Windows as a USB adapter.

Change History

comment:1 Changed 6 years ago by DeadTroll

Same issue here with version 1.5.4.

I have a Toshiba Equium A200-IV0 laptop, Vista Home Premium 32 bit, Realtek Wireless 54Mbps USB adaptor.

Opening VirtualBox causes total loss of connection for the host. First noticed something was amiss when the register VirtualBox failed!

Thank you Zorko for the workaround, which at least gives me a chance to scope this product out :)

comment:2 Changed 6 years ago by EspadaV8

I'm having exactly the same problem on a toshiba l40-pro running vista home basic 32bit. Googling it seems to be a Intel PRO/Wireless 3945ABG card, but since I haven't got the laptop with me at the moment I can't confirm this (or test out the workaround)

Andy

comment:3 Changed 6 years ago by riz

Same issue here with version 1.6.2.

Vista Home Premium 32 bit host, on a Toshiba Equium L40-17M.

Realtek RTL8187B Wireless 802.11b/g 54Mbps USB 2.0 Network Adapter (internal).

The workaround from zorko does not restore connectivity. The only way to do that seems to be to restart the laptop.

comment:4 Changed 6 years ago by frank

  • Host type changed from other to Windows

comment:5 Changed 6 years ago by frank

  • Component changed from other to network

comment:6 Changed 6 years ago by greg86

Same issue here with version 1.6.2. Same built in Realtek controller. Actually disabling and enabling the controller solves the problem, but it's still REALLY ANNOYING!

Please try to fix it.

comment:7 Changed 6 years ago by emptyhead

Hi all,

I've just posted a heavy handed workaround to enable guest net connection on usb wireless cards. See #1712 for details :)

cheers, tAz

comment:8 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #1712 (more info there).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use