VirtualBox

Ticket #8412 (closed defect: obsolete)

Opened 3 years ago

Last modified 3 months ago

Event ID 55 in event log

Reported by: kolmer Owned by:
Priority: major Component: GUI
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: other
Host type: Windows

Description (last modified by frank) (diff)

After installing VirtualBox 4.0.4 and the Oracle VM VirtualBox Extension Pack on a clean installation of Windows 7, one or more of the following events are generated in the event log of the host:

Event ID 55: "The file system structure on the disk is corrupt and unusable. Please run the chkdsk utility on the volume C:"

The volume is marked "dirty" and chkdsk will be started at the next reboot.

This happens when VirtualBox is started for the first time after installation (no virtual machines created) and the “Oracle VM VirtualBox Manager” window is open. After installing the Extension Pack by clicking the .vbox-extpack file from Windows Explorer, a second “Oracle VM VirtualBox Manager” will open. When closing both “Oracle VM VirtualBox Manager” windows, one or more events with ID 55 are generated in the System event log

Although the problem seems to be timing related and does not always occur, I have managed to reproduce it in a more or less reliable way using the following steps:

  1. Delete the VirtualBox.xml and VirtualBox.xml-prev files in the users .VirtualBox directory.
  1. Start two instances of VirtualBox.
  1. Move the “Oracle VM VirtualBox Manager” window of the second instance (the one that has the focus) so that the VirtualBox.xml file (GUI/LastWindowPosition) will be updated.
  1. Move the “Oracle VM VirtualBox Manager” window of the first instance.
  1. Close the first instance.
  1. Close the (remaining) second instance.

After a short investigation, I have the feeling that this problem might be related to a problem with MoveFileEx() described in Microsoft KB982927 (see also  http://social.technet.microsoft.com/Forums/en/w7itprogeneral/thread/df935a52-a0a9-4f67-ac82-bc39e0585148).

I’ve also seen several occurrences of a similar problem when restoring snapshots (as described in #7565). However, I was not able to reproduce this in a reliable way.

Change History

comment:1 Changed 3 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use