VirtualBox

Ticket #8399 (closed defect: invalid)

Opened 3 years ago

Last modified 3 years ago

Unknown version of the X Window System installed.

Reported by: garym Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.0.4 Keywords: guest xwindows
Cc: garym Guest type: Solaris
Host type: Solaris

Description (last modified by ramshankar) (diff)

Upgraded to 4.0.2 and installed guest 4.0.2, upgraded to 4.0.4 and guest 4.0.4 with the same result.

Installing the Guest additions I get error: "Warning: Unknown version of the X Window System installed." The drivers were not installed.

On reboot it did not load virtual box drivers. Xwindows failed to complete loading. I guess the installer didn't lie.

Is there a work around to this issue ?

From the Xorg log file:
(II) Loading extension SolarisIA
(II) LoadModule: "xtsol"
(WW) Warning, couldn't open module xtsol
(II) UnloadModule: "xtsol"
(EE) Failed to load module "xtsol" (module does not exist, 0)
(II) LoadModule: "vboxvideo"
(WW) Warning, couldn't open module vboxvideo
(II) UnloadModule: "vboxvideo"
(EE) Failed to load module "vboxvideo" (module does not exist, 0)
(II) LoadModule: "vesa"
(II) Loading /usr/lib/xorg/modules/drivers/amd64/vesa_drv.so
(II) Module vesa: vendor="X.Org Foundation"
compiled for 1.7.4, module version = 2.2.1
Module class: X.Org Video Driver
ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "fbdev"
(WW) Warning, couldn't open module fbdev
(II) UnloadModule: "fbdev"
(EE) Failed to load module "fbdev" (module does not exist, 0)
(II) VESA: driver for VESA chipsets: vesa
(II) Primary Device is: PCI 00@00:02:0

Xwindows info:
X.Org X Server 1.7.4
Release Date: 2010-01-08
X Protocol Version 11, Revision 0
Build Operating System: SunOS 5.11 i86pc
Current Operating System: SunOS opensolariscloud 5.11 snv_134b i86pc
Build Date: 22 May 2010 10:19:23AM
Solaris ABI: 64-bit

Change History

comment:1 Changed 3 years ago by ramshankar

  • Description modified (diff)

Could you attach the full Installation output? Not just the "Warning: Unknown..." part?

I presume the Xwindows info that you put is directly the output of /usr/bin/Xorg -version

Also is this standard OpenSolaris snv_134n or some modified version of it?

comment:2 Changed 3 years ago by garym

Thanks

the os is snv_134b

The Xwindows version information was taken from the XOrg log file...

Unfortunately, I deleted all the vm images and reinstalled. I'm on a tight deadline... It was over a week since I posted to forums. I just ran out of road.

On these versions of vm, 4.0.4 is installing without issue. I've tried rebooting and removing and adding the Guest Additions 12 times... I can't replicate the problem...

I'm not sure what the issues was, but it was definitely there. I guess we'll have to cancel the ticket..

comment:3 Changed 3 years ago by ramshankar

  • Status changed from new to closed
  • Resolution set to invalid

Okay, thanks for the report, please reopen the ticket if the issue pops up again.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use