VirtualBox

Ticket #8385 (closed defect: fixed)

Opened 3 years ago

Last modified 11 months ago

Can't boot from Secondary Master/Slave IDE

Reported by: Batman Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 4.0.4 Keywords: secondary slave
Cc: Guest type: Windows
Host type: Windows

Description (last modified by aeichner) (diff)

I have created VM with Windows XP guest OS (my host OS is Windows 7). It's main virtual hdd connected to primary master IDE. My host's CD-drive is connected to primary slave. Everything works fine. I have bootable USB-flash disk with DOS installed. Using VBoxManage.exe i created vmdk-file that map my USB-flash to virtual HDD. Next i connect it to my VM as secondary master IDE. But i can't boot from this drive! Durin startup i press F12 (to enter boot menu), than select Secondary Master and get error message: Start booting from USB device... Boot disk failure But my USB-flash is definitely bootable! (see VBox1.log attached)

Then i remove all my drives from VM and connect only USB-flash as primary master. And boot was successful. Next i add back my main virtual hdd (with winxp installed) as primary slave. And i can't boot from this slave. Only primary master IDE is bootable!

I created another VM (DOS-type) with another VDI-file (but i did not install DOS there because did not want to waste time) connected as primary master. My host's DVD-ROM connected as primary slave. USB-flash vmdk file connected as secondary master. The problem persists (see VBox2.log attached) - i can't boot from secondary master (or any slave).

PS: the same problem i have with my external bootable USB-HDD (not flash).

My VirtualBox version is 4.0.4 r70112.

Attachments

VBox1.log Download (66.0 KB) - added by Batman 3 years ago.
VBox2.log Download (63.5 KB) - added by Batman 3 years ago.
usb_flash.vmdk Download (633 bytes) - added by Batman 3 years ago.
My USB-flash drive mapping file

Change History

Changed 3 years ago by Batman

Changed 3 years ago by Batman

Changed 3 years ago by Batman

My USB-flash drive mapping file

comment:1 Changed 11 months ago by aeichner

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

Not reproducible with a recent release of VirtualBox. Closing, please reopen if necessary.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use