VirtualBox

Ticket #8376 (closed defect: fixed)

Opened 3 years ago

Last modified 15 months ago

Regression: vboxdrv-module crashes and running machine freezes

Reported by: ManU Owned by:
Priority: critical Component: virtual disk
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description (last modified by frank) (diff)

running system upgrades under gentoo breaks virtualbox

worked in 3.2.12! doesn't work since 4.x.x

 http://pastie.org/1579480

Feb 18 18:18:37 P7P55D-E -- MARK --
Feb 18 18:22:20 P7P55D-E kernel: BUG: unable to handle kernel NULL pointer dereference at   (null)
Feb 18 18:22:20 P7P55D-E kernel: IP: [<f965c213>] 0xf965c213
Feb 18 18:22:20 P7P55D-E kernel: *pde = 00000000 
Feb 18 18:22:20 P7P55D-E kernel: Oops: 0000 [#1] PREEMPT SMP 
Feb 18 18:22:20 P7P55D-E kernel: last sysfs file: /sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/device:03/ATK0110:00/hwmon/hwmon0/temp1_label
Feb 18 18:22:20 P7P55D-E kernel: Modules linked in: md5 hmac nls_utf8 cifs fscache sco bnep l2cap ipv6 bluetooth coretemp rfkill ext3 jbd aes_i586 aes_generic xts gf128mul dm_crypt n
ls_cp437 vfat fat snd_seq_dummy raid1 md_mod snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device nvidia(P) snd_pcm_oss snd_mixer_oss snd_hda_codec_hdmi joydev agpgart usbhid hid sn
d_hda_codec_via asus_atk0110 firewire_ohci firewire_core crc_itu_t r8169 mii ati_remote wacom dm_mod snd_hda_intel s
nd_hda_codec snd_hwdep snd_pcm snd_timer snd soundcore snd_page_alloc button pcspkr uinput processor shpchp pci_hotplug sg evdev i2c_i801 i2c_core iTCO_wdt iTCO_vendor_support fuse vboxnetflt vboxdrv ext4 mbcache jbd2 crc16 sr_mod cdrom sd_mod usb_storage pata_acpi xhci_hcd pata_jmicron ahci libahci libata ehci_hcd usbcore scsi_mod
Feb 18 18:22:20 P7P55D-E kernel: 
Feb 18 18:22:20 P7P55D-E kernel: Pid: 15730, comm: VirtualBox Tainted: P            2.6.37-ARCH #1 P7P55D-E/System Product Name
Feb 18 18:22:20 P7P55D-E kernel: EIP: 0060:[<f965c213>] EFLAGS: 00010246 CPU: 3
Feb 18 18:22:20 P7P55D-E kernel: EIP is at 0xf965c213
Feb 18 18:22:20 P7P55D-E kernel: EAX: 00000000 EBX: ec791d90 ECX: 00000003 EDX: 00000000
Feb 18 18:22:20 P7P55D-E kernel: ESI: 00000001 EDI: 0000280a EBP: ec791d70 ESP: ec791d48
Feb 18 18:22:20 P7P55D-E kernel: DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
Feb 18 18:22:20 P7P55D-E kernel: Process VirtualBox (pid: 15730, ti=ec790000 task=f246ebd0 task.ti=ec790000)
Feb 18 18:22:20 P7P55D-E kernel: Stack:
Feb 18 18:22:20 P7P55D-E kernel: f8e81000 ec791d64 c1312aae 00000002 ec791df4 f8e81000 ec791db0 00000000
Feb 18 18:22:20 P7P55D-E kernel: f8e62000 f8e81000 ec791db0 f9634ae6 ec791d90 f8e81000 00000000 00000000
Feb 18 18:22:20 P7P55D-E kernel: c14b6340 f246ebd0 c14b6340 c14b6340 f246ed94 c14b6340 c14b6340 00101000
Feb 18 18:22:20 P7P55D-E kernel: Call Trace:
Feb 18 18:22:20 P7P55D-E kernel: [<c1312aae>] ? schedule+0x28e/0x9e0
Feb 18 18:22:20 P7P55D-E kernel: [<c1073fea>] ? get_futex_key+0x10a/0x140
Feb 18 18:22:20 P7P55D-E kernel: [<c103dd22>] ? enqueue_entity+0x102/0x170
Feb 18 18:22:20 P7P55D-E kernel: [<c1033732>] ? enqueue_task+0x32/0x80
Feb 18 18:22:20 P7P55D-E kernel: [<c103305d>] ? check_preempt_curr+0x5d/0x80
Feb 18 18:22:20 P7P55D-E kernel: [<c103ee6d>] ? try_to_wake_up+0x19d/0x330
Feb 18 18:22:20 P7P55D-E kernel: [<f8f3a290>] ? VBoxDrvLinuxIOCtl+0x0/0x1c0 [vboxdrv]
Feb 18 18:22:20 P7P55D-E kernel: [<f8f3cec9>] ? supdrvIOCtlFast+0x99/0xb0 [vboxdrv]
Feb 18 18:22:20 P7P55D-E kernel: [<f8f3a2cc>] ? VBoxDrvLinuxIOCtl+0x3c/0x1c0 [vboxdrv]
Feb 18 18:22:20 P7P55D-E kernel: [<c10738f1>] ? wake_futex+0x31/0x50
Feb 18 18:22:20 P7P55D-E kernel: [<c1075ddf>] ? do_futex+0x52f/0x8d0
Feb 18 18:22:20 P7P55D-E kernel: [<f8f3a290>] ? VBoxDrvLinuxIOCtl+0x0/0x1c0 [vboxdrv]
Feb 18 18:22:20 P7P55D-E kernel: [<c1111e5a>] ? do_vfs_ioctl+0x7a/0x590
Feb 18 18:22:20 P7P55D-E kernel: [<c1003eb0>] ? common_interrupt+0x30/0x38
Feb 18 18:22:20 P7P55D-E kernel: [<c1104d91>] ? fget_light+0x91/0xb0
Feb 18 18:22:20 P7P55D-E kernel: [<c11123cf>] ? sys_ioctl+0x5f/0x80
Feb 18 18:22:20 P7P55D-E kernel: [<c100391f>] ? sysenter_do_call+0x12/0x28
Feb 18 18:22:20 P7P55D-E kernel: [<c1310000>] ? end_local_APIC_setup+0xf5/0x11d
Feb 18 18:22:20 P7P55D-E kernel: Code: 00 74 a7 eb 9e 8d 76 00 55 89 e5 53 83 ec 24 8b 55 0c 8b 5d 08 8b 82 dc 36 00 00 85 c0 89 45 f4 74 1d 8b 55 10 83 e2 03 8d 14 d0 <8b> 02 8b 52 04 89 03 89 d8 89 53 04 83 c4 24 5b 5d c2 04 00 8d 
Feb 18 18:22:20 P7P55D-E kernel: EIP: [<f965c213>] 0xf965c213 SS:ESP 0068:ec791d48
Feb 18 18:22:20 P7P55D-E kernel: CR2: 0000000000000000
Feb 18 18:22:20 P7P55D-E kernel: ---[ end trace e5e39f10cb83b528 ]---
Feb 18 18:22:20 P7P55D-E kernel: note: VirtualBox[15730] exited with preempt_count 1

Attachments

crash.log Download (6.7 KB) - added by ManU 3 years ago.
kernelog and vboxlog

Change History

comment:1 in reply to: ↑ description Changed 3 years ago by ManU

Host: ArchLinux Guest: Gentoo

comment:2 Changed 3 years ago by frank

  • Description modified (diff)

Which is the last VBox 4 version you tried?

comment:3 Changed 3 years ago by ManU

4.0.4 it is still a regression bug, since in 3.2.12 it worked!

comment:4 Changed 3 years ago by frank

To me it looks like some special kernel config setting. Please could you attach your kernel configuration? 2.6.37 works very well here...

comment:5 Changed 3 years ago by ManU

frank with this kernel vbox 3.2.12 runs without problems (compiled against this kernel), this bug exists since 4.0. with the latest windows release it does work also.

i think its a regression-bug in the linux fork... how to paste the config settings? i dont compile kernels by myself

comment:6 Changed 3 years ago by ManU

I tested it under Windows as host, there all works fine with: vbox 4.0.4r7xxx

so its only a regression in the linux fork since 4.0.0

comment:7 Changed 3 years ago by frank

Can you attach a VBox.log file from a VM session where this crash happens? Regarding the kernel config, I don't know where Gentoo stores the kernel config but it is normally the file .config in the root directory of the Linux tree.

comment:8 Changed 3 years ago by ManU

Crashes also with kernel 2.6.38, here is the log:

 http://pastie.org/1787849

comment:9 Changed 3 years ago by ManU

does the log help?

comment:10 Changed 3 years ago by ManU

Also crashing with 4.06 r71344  http://pastie.org/1821956

but sicne 4.0.4 the bug changed from a total crash of vboxdrv to this strnge mouse pointer bug, but the result is the same, i need to kill the virtual machine process.

under windows it does work and also with other hosts. it also does not work with any mac osx guest if that helps...

comment:11 Changed 3 years ago by ManU

Also crashing with 4.08 r71778 The module doesnt crash anymore, but the whole VM-windows freezes

comment:12 Changed 3 years ago by ManU

before freezing the window flickers fast between black and the graphical Xserver of the vm

comment:13 Changed 3 years ago by ManU

also happens with release 4.1.2

the module crashes and the window freezes

Changed 3 years ago by ManU

kernelog and vboxlog

comment:14 Changed 3 years ago by frank

Please attach the complete VBox.log file of this session to this ticket. Do NOT paste the content!

comment:15 Changed 3 years ago by frank

This could be also related to #7390 so if your guest uses PAE, try to disable it.

comment:16 Changed 15 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use