VirtualBox

Ticket #8369 (closed defect: obsolete)

Opened 3 years ago

Last modified 3 months ago

NAT: CIFS connection to host is terribly slow

Reported by: birdie Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 4.0.4 Keywords: nat
Cc: Guest type: Linux
Host type: Linux

Description (last modified by frank) (diff)

Probably NAT is not meant for transferring data between host OS and guest OS, but since it's possible I suppose such a connection should have a speed comparable to Host-only connection.

However it's not the case.

When copying data from Fedora 14 guest to Fedora 14 host (both have i686 arch) I get 196KB/sec connection speed on average. Both hosts are 100% idle when copying (host OS exports SMB shares, guest OS has them mounted via CIFS).

When I copy data using Host-only adapter the speed soars to 20-30MB/sec.

P.S. Guest additions are not installed. Guest OS has Intel PRO/1000MT Desktop (82540EM) adapter.

Attachments

copying.png Download (31.2 KB) - added by birdie 3 years ago.
Low speed when copying a file from a guest OS to a host OS - screenshot
VBox.nat.log.gz Download (8.5 KB) - added by birdie 3 years ago.
NAT'ted VBox.log
VBox.hostonly.log.gz Download (8.4 KB) - added by birdie 3 years ago.
Host-only VBox.log
ffsb.nat Download (3.4 KB) - added by birdie 3 years ago.
ffsb NAT results
ffsb.hostonly Download (3.3 KB) - added by birdie 3 years ago.
ffsb host-only results

Change History

Changed 3 years ago by birdie

Low speed when copying a file from a guest OS to a host OS - screenshot

comment:1 Changed 3 years ago by Hachiman

Could you please attach the log file?

comment:2 Changed 3 years ago by Hachiman

could you please attach output of  ffsb for NAT and host-only?

comment:3 follow-up: ↓ 4 Changed 3 years ago by birdie

Please, give me a ffsb profile to test. There are eight exemplary ones, I've no idea which one to use.

Changed 3 years ago by birdie

NAT'ted VBox.log

Changed 3 years ago by birdie

Host-only VBox.log

comment:4 in reply to: ↑ 3 Changed 3 years ago by Hachiman

Replying to birdie:

Please, give me a ffsb profile to test. There are eight exemplary ones, I've no idea which one to use.

please use profile_everything config with replacing location property with path to some test folder on smb/cifs share.

[filesystem]
   location = 

Changed 3 years ago by birdie

ffsb NAT results

Changed 3 years ago by birdie

ffsb host-only results

comment:5 follow-up: ↓ 6 Changed 3 years ago by birdie

I don't know how these results can be helpful - since that's exactly what I've said in the first post.

comment:6 in reply to: ↑ 5 Changed 3 years ago by Hachiman

Replying to birdie:

I don't know how these results can be helpful - since that's exactly what I've said in the first post.

Benchmark is more obvious to simplify the test case than real application (in case if benchmark has the same behavior as application ofc). Particular this benchmark do several operations, and more flexible with initial parameters, and shows wider specter of CIFS related issues.

BTW: If the behavior of mc is the same for NFS share for you?

comment:7 follow-up: ↓ 8 Changed 3 years ago by birdie

I did a better and cleaner test (while using NAT connection):

On host:

$ nc -l 1234 > file.temp

On guest

$ time nc 10.0.2.2 1234 < /proc/kcore real : 1m10s

kcore weighs 1,032,188K, so we're getting 14,745KB/sec speed which is (I suppose) close to the theoretical maximum since guest is eating 100% of the host CPU at this moment.

So, actually I don't know what to do with this bug report - it's 100% reproducible using CIFS connection, it doesn't hold true when I use direct TCP connection (e.g. using nc/netcat).

comment:8 in reply to: ↑ 7 ; follow-up: ↓ 10 Changed 3 years ago by Hachiman

Replying to birdie:

So, actually I don't know what to do with this bug report - it's 100% reproducible using CIFS connection, it doesn't hold true when I use direct TCP connection (e.g. using nc/netcat).

I'll just change the header to mark as CIFS specific.

comment:9 Changed 3 years ago by Hachiman

  • Summary changed from NAT connection to host is terribly slow to NAT: CIFS connection to host is terribly slow

comment:10 in reply to: ↑ 8 Changed 3 years ago by Hachiman

Replying to birdie:

So, actually I don't know what to do with this bug report - it's 100% reproducible using CIFS connection, it doesn't hold true when I use direct TCP connection (e.g. using nc/netcat).

Does it look host/guest specific, e.g. you don't see the same effects with CIFS on other guests or hosts? Here on Mac and Ubuntu hosts I don't see such dramatical performance slowdown on CIFS.

comment:11 Changed 3 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use