VirtualBox

Ticket #8322 (closed defect: duplicate)

Opened 3 years ago

Last modified 12 months ago

Windows version of VirtualBox should declare itself DPI-aware

Reported by: Sophie Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.2 Keywords:
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

I use a custom DPI setting on Windows and as far as I can tell, VirtualBox is fine with high DPI settings. However, it doesn't  declare itself DPI-aware, meaning that on Windows 7 by default it will be subject to DPI Virtualization, where the OS gives the app an off-screen 96 DPI surface to draw on, which the OS then scales up for display. Needless to say, this results in blurry interfaces. I think it's probably a good idea if VirtualBox were to declare itself DPI-aware.

Normally I'd get around this by setting the compatibility properties, but my version of VirtualBox is a 64-bit app and as such, Windows 7 doesn't allow me to change those.

Attachments

virtualbox-dpi.png Download (126.4 KB) - added by Sophie 3 years ago.
VirtualBox main window at 120 DPI - notice the names and statuses are cut off

Change History

comment:1 Changed 3 years ago by Sophie

For the record, I'm currently getting around this by editing the manifest myself. Adding the appropriate tags (see the page UI linked in the bug) allows VirtualBox to work just fine.

comment:2 Changed 3 years ago by Sophie

This appears to have been fixed in 4.1.0. For the first time, I haven't found it necessary to add the manifest tags. :)

comment:3 Changed 3 years ago by Sophie

That said, I'm not entirely sure *why* it's fixed in 4.1.0, since I don't see any changes to the manifest, and I don't yet see a SetProcessDPIAware call. Maybe it's something I've done. I'll see if I can find anything out.

comment:4 Changed 3 years ago by Sophie

Also, it looks like it now deals with DPI wrongly in the machine list, causing names to get cut off. I'll upload a screenshot - this was taken at 120 DPI on Windows 7 64-bit.

Changed 3 years ago by Sophie

VirtualBox main window at 120 DPI - notice the names and statuses are cut off

comment:5 Changed 3 years ago by Sophie

I've downgraded back to 4.0.12 because it's hard to tell between VMs with this bug, and 4.0.12 works fine, even with the patched manifest that tells Windows that VirtualBox is DPI-aware. I'm happy to upgrade to 4.1.0 for additional testing, though.

comment:6 Changed 2 years ago by Sophie

This (that is, the text being cut off as shown in the image) is still occurring in 4.1.6.

If I can do anything to help track down this bug, please let me know. (I'm fairly certain it's to do with DPI settings though! To be clear, in Windows 7 that's the "Make text and other items larger or smaller" part of the Control Panel.)

comment:7 Changed 12 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
  • Description modified (diff)

Duplicate of #9864 and fixed in VBox 4.2.x.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use