VirtualBox

Ticket #8316 (closed defect: worksforme)

Opened 3 years ago

Last modified 3 years ago

virtualbox GUI crashes in ig4icd64.dll on guest shutdown -> Update host graphics drivers

Reported by: trondhuso Owned by:
Priority: major Component: GUI/seamless
Version: VirtualBox 3.2.12 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

When I (or the system) reboots or shutdown Ubuntu Guest on Windows 7 64-bit host system, virtualbox GUI crashes.

How to reproduce: Start up Virtualbox Start up Ubuntu Guest Login to Ubuntu Guest Choose shutdown (or reboot) on the menu.

Attachments

Ubuntu 10.04 386-2011-02-10-13-16-48.log Download (51.9 KB) - added by trondhuso 3 years ago.
Logfile of Ubuntu guest OS-file
Ubuntu 10.04 386-2011-02-10-14-17-47.log Download (64.0 KB) - added by trondhuso 3 years ago.
Logfile of Ubuntu guest OS-file after upgrade to 2.3.13

Change History

Changed 3 years ago by trondhuso

Logfile of Ubuntu guest OS-file

comment:1 Changed 3 years ago by sunlover

Please check if  this build fixes the problem. Thanks.

Changed 3 years ago by trondhuso

Logfile of Ubuntu guest OS-file after upgrade to 2.3.13

comment:2 Changed 3 years ago by trondhuso

Same result after upgrade.

comment:3 Changed 3 years ago by sunlover

Does the GUI crash as well with other guests? Or only the Ubuntu guest causes the crash?

comment:4 Changed 3 years ago by trondhuso

Windows is no problem. Fedora was no problem.

It seems like it could be the Ubuntu installation. Maybe I should reinstall.

comment:5 Changed 3 years ago by sunlover

It would be good to have a dump of the crash. How to do it on Windows 7 is explained  here in the "To collect user-mode dumps" section, where the registry key "Windows Error Reporting\LocalDumps" is used.

If you'll get this dump, you could send the files from CrashDumps directory to me at Vitali dot Pelenjow at oracle dot com

comment:6 Changed 3 years ago by sunlover

Thank you for the dump. It shows that the crash happens in the host graphics driver ig4icd64.dll. Please try to install the latest version of the graphics driver. Also try to disable 3D for the VM and check if the crash still happens.

comment:7 Changed 3 years ago by trondhuso

Updated driver and BIOS (since there was a new one available).

Started ubuntu guest. Logged in. Rebooted. No error and guest rebooted without any problems. It runs 3D.

Tried to disable 3D earlier and the whole screen got filled with characters...

Thanks for all the help!

comment:8 Changed 3 years ago by sunlover

  • Status changed from new to closed
  • Resolution set to worksforme
  • Summary changed from virtualbox GUI crashes on ubuntu guest shutdown to virtualbox GUI crashes in ig4icd64.dll on guest shutdown -> Update host graphics drivers

Thanks. So it was a problem with the host graphics card drivers.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use