VirtualBox

Ticket #8286 (new defect)

Opened 3 years ago

Last modified 3 years ago

Host USB mouse lost

Reported by: marcox Owned by:
Priority: minor Component: USB
Version: VirtualBox 4.0.0 Keywords:
Cc: Guest type: other
Host type: Windows

Description

XP x64 host, various guests. Quite often but not always, when I start the VBox Manager or when (with VBox Manager running) I plug or unplug an USB device, my mouse pointer freezes. To have my mouse back working I must unplug it and plug it again. No messages whatsoever are shown.

This has nothing to do with any particular VM, as it happens also when no VMs are opened or running. That's why I'm not attaching any VM's log file (I wouldn't know which one to choose). Anyway, I also checked filters: no usb filters regarding the usb mouse are set in any VMs.

This has been happening, more or less frequently, throughout multiple VBox's releases and also happens now, with 4.0.0. It looks like VBox has some problems in dealing with the mouse being both an "usb device" amongst the others and also the "host's system mouse".

Change History

comment:1 Changed 3 years ago by marcox

Any news about this issue?

comment:2 Changed 3 years ago by frank

Not really. But I have a question: Did you pass your host USB mouse to the guest? And does that also occur if you start VMs with a disabled (virtual) USB controller at all?

comment:3 Changed 3 years ago by marcox

I don't understand well the first question: what do you mean with "pass to the guest"? Supposing you are talking about USB filters I can say, as I said, that I have no USB filters for the mouse in any VM. There is no need for that (rightly, I think) as the host's mouse get captured anyway by the VM together with the keyboard.

The answer to the second question is yes. As I said, the freezing randomly occurs even with no running or open VMs (= with the only VBox Manager running). It seems that when the Vbox Manager is running any change in the USB situation (starting a VM which has to capture the mouse or simply plugging in a USB device or switching the USB printer on) can produce a pointer freeze, which gets always solved as soon as the mouse get unplugged and immediately plugged again.

comment:4 follow-up: ↓ 5 Changed 3 years ago by mhanor

Have you tried reinstalling VirtualBox without the USB support? How about uninstalling VB altogether, to see if your issue is independent of it?

comment:5 in reply to: ↑ 4 Changed 3 years ago by misha

The new VBox 4.1 has major USB functionality rewrite for Windows hosts, please try VBox 4.1 to see if the issue is fixed there. If it's not please try doing what mhanor suggests.

comment:6 Changed 3 years ago by marcox

Thanks for your help.
No, I haven't tried uninstalling or reinstalling VBox.
I've been experiencing this issue for a long time and I've got somehow used to it. As I said, it happens every now and then and is easily "fixable" (stand up, reach the back of the PC, unplug the mouse and plug it again); apart from that, everything I need from VBox works, so I do not consider it worth uninstalling or reinstalling.
Anyway I can assure that I never get pointer freezes when VBox Manager is not running.

As to release 4.1, I plan to wait for a couple of maintenance releases before upgrading (I've learned to tread quite carefully, especially when things work without major problems).
However I just read in the "Discuss the 4.1 release" forum a post from someone having the same "longstanding" issue who did the upgrade and says "...the frequency has definitely picked up since installing version 4.1.0".

comment:7 Changed 3 years ago by marcox

Has this issue been "officially" spotted/fixed yet?

comment:8 Changed 3 years ago by mhanor

Try this: go to Display Properties -> Settings -> Advanced -> Troubleshoot, set Hardware acceleration from the most right setting (Full - All accelerations are enabled), to one step left of it (Disable cursor and bitmap acceleration).

comment:9 Changed 3 years ago by marcox

Thanks for the advice. Unfortunately, following it I got no improvement.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use