VirtualBox

Ticket #8284 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

running tracepath inside VM crashes virtualbox

Reported by: yrro Owned by:
Priority: blocker Component: network/hostif
Version: VirtualBox 4.0.0 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Running the 'tracepath' command from iputils 3:20100418-3 inside a VM running Debian 6.0 (linux 2.6.32) causes VirtualBox to instantly freeze, in such a severe manner that it is not even possible to kill it via the task manager. The host must be rebooted in order to recover.

Attachments

wintermute.xml Download (9.4 KB) - added by yrro 3 years ago.
VM configuration
VBox.log Download (55.2 KB) - added by yrro 3 years ago.
vm log file

Change History

Changed 3 years ago by yrro

VM configuration

Changed 3 years ago by yrro

vm log file

comment:1 Changed 3 years ago by frank

  • Component changed from other to network/hostif

comment:2 Changed 3 years ago by defbass

I can confirm that this problem still exists in version 4.0.2

comment:3 Changed 3 years ago by gof

I can also confirm that this is present as a problem on Virtualbox 4.0.4 with a gentoo host and gentoo client.

comment:4 Changed 3 years ago by p0rk

I can confirm this bug on Gentoo Linux (host) running VirtualBox 4.0.8 r71778 with two Scientific Linux 6.0 (RHEL fork) guests tracepath-ing each other via an internal network using paravirtualized network devices.

comment:5 Changed 3 years ago by sjurso

Confirmed, at the end I was stuck with a zombie process consuming almost all CPU - had to force reboot using Sysrq since even the host wouldn't go down.

Virtualbox 4.1.2 64bit host, 32 bit guests, virtio_net. Using recent kernels and userland.

comment:6 Changed 2 years ago by klaus

Can't reproduce. Since there are reports for various host OSes I assume this plays no role, and I made my test with Debian 5.0 as the host, and Debian 6.0 as the guest. Networking mode was "bridged", and I used a wired Gbit ethernet card. I could get paths with up to 21 hops, without any trouble. Tried 4.0.14 and latest svn sources.

comment:7 Changed 2 years ago by f15h

I had the same problem with 4.0.12. Updated to 4.1.4 and the problem is gone. It looks like this bug can be closed as fixed.

comment:8 Changed 2 years ago by Hachiman

Does (or was) it depend on attachment of device to wireless or ethernet one?

comment:9 Changed 2 years ago by yrro

Confirming that I can no longer reproduce this in VirtualBox 4.1.4.

comment:10 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use