VirtualBox

Ticket #8259 (closed defect: worksforme)

Opened 3 years ago

Last modified 3 years ago

Vbox send packages to network even with "virtual cable" disconnected

Reported by: luizluca Owned by:
Priority: major Component: network
Version: VirtualBox 4.0.2 Keywords:
Cc: Guest type: other
Host type: Linux

Description

Hello,

With the vm running, I clicked on the vbox net config, unselected "connected cable" checkbox and pressed OK. However, vm still sends packages to network.

In my case, vbox is attached to a tap interface (because I need a richer NAT) and I use dnsmasq as my dhcp server.

I will attach a screenshot with the wireshark trace, the VM screen showing ipconfig, network config window showing the unckecked checkbox and some host syslog messages.

Change History

comment:1 Changed 3 years ago by luizluca

Sorry, it seems that vboxnet or something else got crazy after some host "Suspend to disk". After a cold reboot, it worked as usual. When I uncheck the box, windows notice that the cable is unconnected as expected.

As I cannot reproduce it again, I guess this bug might be invalid.

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

Feel free to reopen this ticket if you can reproduce the problem.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use