VirtualBox

Ticket #8249 (closed defect: duplicate)

Opened 3 years ago

Last modified 2 years ago

Enabling page fusion causes AssertLogRel errors in pgmR3SharedModuleRegRendezvous in VBox.log

Reported by: dllexport Owned by:
Priority: major Component: VMM
Version: VirtualBox 4.0.2 Keywords: page fusion, pgmR3SharedModuleRegRendezvous
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

On a Linux/x64 host with AMD-V enabled with Windows 2003 R2 x64 guests, the following error is repeatedly logged in VBox.log when page fusion is enabled:

AssertLogRel /home/vbox/vbox-4.0.2/src/VBox/VMM/VMMR3/PGMSharedPage.cpp(207) 
VBOXSTRICTRC pgmR3SharedModuleRegRendezvous(VM*, VMCPU*, void*): RT_SUCCESS_NP(rc)
147:58:33.520 VERR_INVALID_PARAMETER (-2) - Invalid parameter.

The error appears even if only one guest is running.

Page fusion also does not work. The "host RAM/VMM/Shared" metric is always 0kb, as is "Guest/RAM/Usage/Shared".

Attachments

VBox.log Download (70.0 KB) - added by dllexport 3 years ago.

Change History

Changed 3 years ago by dllexport

comment:1 Changed 3 years ago by frank

Is there any debug output in the host kernel log (dmesg)?

comment:2 Changed 3 years ago by dllexport

There is nothing in the host kernel log. I tried restarting one of the VMs in case I missed something, but there is nothing.

comment:3 Changed 2 years ago by deller

Same output is still generated with VirtualBox 4.0.14:

00:15:43.221 AssertLogRel /home/vbox/vbox-4.0.14/src/VBox/VMM/VMMR3/PGMSharedPage.cpp(207) VBOXSTRICTRC pgmR3SharedModuleRegRendezvous(VM*, VMCPU*, void*): RT_SUCCESS_NP(rc) 00:15:43.221 VERR_INVALID_PARAMETER (-2) - Invalid parameter.

I'm not sure if page fusion really works though. At least it does not seem efficient.

When running "VBoxManage metrics collect" I can see: 22:11:08.342 host RAM/VMM/Shared 35264 kB 22:11:08.342 host RAM/VMM/Shared:avg 35264 kB 22:11:08.342 host RAM/VMM/Shared:min 35264 kB 22:11:08.342 host RAM/VMM/Shared:max 35264 kB but 35MB is really very little for two identical Windows XP machines with running the identical huge applications at the same time....?

comment:4 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
  • Description modified (diff)

Let's close this as duplicate of #7278.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use