VirtualBox

Ticket #8247 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

Solaris 8 guest crashes in VirtualBox 4.0.2 => fixed in svn

Reported by: rorth Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.2 Keywords:
Cc: Guest type: Solaris
Host type: Solaris

Description (last modified by frank) (diff)

While I've successfully run a Solaris 8 guest in VirtualBox 3.1.8 up to Solaris 11 Express, it causes memory exhaustion on snv_155.

I now tried to run the same guest in VirtualBox 4.0.2 on snv_157. Unfortunately, the guest crashes now, while a Solaris 9 guest at least boots.

Attachments

VBox.log Download (142.0 KB) - added by rorth 3 years ago.
log file

Change History

Changed 3 years ago by rorth

log file

comment:1 follow-up: ↓ 2 Changed 3 years ago by sunlover

This could be the same problem as in ticket #7966.

Try to disable the preview window in the VirtualBox Console.

comment:2 in reply to: ↑ 1 Changed 3 years ago by rorth

Replying to sunlover:

This could be the same problem as in ticket 7966:

 http://www.virtualbox.org/ticket/7966

Try to disable the preview window in the VirtualBox Console.

No, this is unrelated: the leak only happens with VirtualBox 3.1.8 on Solaris 11 builds after snv_151a (Solaris 11 Express). The S8 VM crashes just the same without the preview window.

Rainer

comment:3 Changed 2 years ago by frank

  • Description modified (diff)

Duplicate of #7589. It would work also work if you would enable VT-x and nested paging. But we want to fix this bug for non-VT-x CPUs as well.

comment:4 Changed 2 years ago by dbeusee

My ticket, #9445, has been marked dup of this one. As I noted in ticket #9445, setting the VM to VT-x doesn't work because that setting hangs the bootup where it says: Running Configuration Assistant... So I cannot run my VM until this issue is fixed.

comment:5 follow-up: ↓ 6 Changed 2 years ago by michaln

  • Summary changed from Solaris 8 guest crashes in VirtualBox 4.0.2 to Solaris 8 guest crashes in VirtualBox 4.0.2 => fixed in svn

Well, Frank did say "if you enable VT-x and nested paging". Presumably your CPU doesn't have nested paging.

At any rate, both problems are fixed in the source tree now.

comment:6 in reply to: ↑ 5 Changed 2 years ago by rorth

Replying to michaln:

Well, Frank did say "if you enable VT-x and nested paging". Presumably your CPU doesn't have nested paging.

Unfortunately, this doesn't work for me either: I'm currently running VirtualBox 4.1.14 on Solaris 11 Update 1 (s11u1_12) on a ThinkPad W510 with an 1.6 GHz Core i7-Q720.

When I enable both VT-x and nested paging, booting a Solaris 8 VM hangs at

Running Configuration Assistant...

with the VirtualBox process consuming a whole core. Same if I leave VT-x enabled, but disable nested paging.

A Solaris 9 VM on the other hand boots just fine if VT-x and nested paging are disabled, but as soon as I enable both, I observe the same hang as with the Solaris 8 VM.

At any rate, both problems are fixed in the source tree now.

Any idea when this will be released?

Thanks.

Rainer

comment:7 Changed 2 years ago by michaln

Sorry, I wasn't precise enough. To run Solaris 7/8/9 successfully with current VirtualBox releases on an Intel CPU, you need nested paging and unrestricted guest execution support. The Core i7-Q720 has the former but not the latter. Unrestricted execution requires nested paging and VirtualBox always enables if it it's available.

On your system, nested paging actually has no impact on the Solaris boot loader due to the lack of unrestricted execution support in hardware.

comment:8 follow-up: ↓ 9 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

The fix is part of VirtualBox 4.1.16.

comment:9 in reply to: ↑ 8 Changed 2 years ago by rorth

Just tried it and it works like a charm. Thank you so much.

Rainer

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use