VirtualBox

Ticket #820 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

Windows guest needs to have an window opened when running Compiz on Ubuntu host

Reported by: Lunks Owned by: umoeller
Priority: minor Component: GUI/seamless
Version: VirtualBox 1.5.0 Keywords:
Cc: Guest type: other
Host type: Linux

Description

When running Windows as a guest (seamless mode) on Ubuntu+Compiz Fusion, desktop is not drawed correctly and does not behaviour correctly either. If I have one window opened, then everything is fine. If not, it's really strange. Screenshot included.

Change History

comment:1 Changed 6 years ago by Lunks

Couldn't attach screenshot, used imageshack instead:  http://img248.imageshack.us/my.php?image=screenshotkt7.png

comment:2 follow-up: ↓ 3 Changed 6 years ago by sandervl73

Try with 1.5.2.

comment:3 in reply to: ↑ 2 Changed 6 years ago by chrisch

Replying to sandervl73:

Try with 1.5.2.

I too have tried upgrading to 1.5.2 on Gutsy with the same issue as stated. I disabled Compiz and Seamless mode runs great. With Compiz enabled, I must keep a Windows program open to view my Ubuntu desktop

comment:4 Changed 6 years ago by samwise

Same here. Running VirtualBox OSE 1.5.2 on Debian AMD64 Testing with a Windows XP Pro guest with the 1.5.2 PUEL Windows Guest Additions. When the last Windows window is minimised, the space it occupied on the screen still shows that application, so it appears to still be open, when it isn't.

Minimising and maximising the VirtualBox app fixes the screen, but only if all the linux apps have been minimised. If you then restore and then minimise a Windows app, the same occurs again.

Quite annoying, really!

comment:5 Changed 6 years ago by lalo

1.5.4 OSE on Ubuntu Gutsy and Compiz 0.7.0, I still see this issue.

comment:6 Changed 6 years ago by umoeller

  • Owner set to umoeller
  • Status changed from new to assigned

I can confirm the problem. Internal bug #2661.

comment:7 Changed 6 years ago by javispedro

I think there is also a  Ubuntu bug report for this.

comment:8 Changed 6 years ago by wolfie2x

confirmed in VirtualBox 2.0.0. This was the same in 1.6.2 too. This bug is 1 year old and still with 'minor' priority.. ;(

comment:9 Changed 6 years ago by frank

  • Host type changed from other to Linux
  • Component changed from other to GUI

Not 1 year, only 11 months. Just kidding. No, we don't want to bother you if we don't yet fixed this problem. The reason is that we first had to migrate the GUI to Qt4. The next step will be solving all these compiz and Xinerama issues which are still present.

comment:10 Changed 6 years ago by frank

  • Component changed from GUI to GUI/seamless

comment:11 follow-up: ↓ 12 Changed 5 years ago by captainc

This problem still exists on Ubuntu 8.10 64-bit with VirtualBox 2.0.6.

Curious, is the solution on the side of VirtualBox, Ubuntu, or Compiz Fusion?

comment:12 in reply to: ↑ 11 Changed 5 years ago by captainc

comment:13 Changed 4 years ago by umoeller

  • Status changed from assigned to closed
  • Resolution set to fixed

This works for me now.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use