VirtualBox

Ticket #82 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

VBoxVRDP process eating lots of memory

Reported by: rpc Owned by: frank
Priority: critical Component: other
Version: VirtualBox 1.3.4 Keywords:
Cc: Guest type: other
Host type: other

Description

Hello folks,

I have recently upgraded to 1.3.4 and i can see that there is something wrong with memory usage on one of my VMs. It's Windows XP guest with 256MB of ram running headless on Etch host with VRDP on. With 1.3.2 i have never seen the VBoxVRDP using more than defined mem size for guest plus 10-15% max (libs and so on). I just saw output from top that got me frozen:

2654 rpc 15 0 906m 875m 3736 S 38 43.2 287:15.45 VBoxVRDP

The process no. 2654 is VBoxVRDP running that XP guest with 256MB of ram. As you can see it is using 875MB of ram right now and that's after ~12h since the VM was started.

It has never happened with 1.3.2 which i was running for several weeks and the total mem usage for that machine never exceeded 300-320MB. Also nothing has changed on the host as for kernel version/options, etc. I will be happy to help you track this bug down in any way i can. Please let me know what additional info you might require.

Change History

comment:1 follow-up: ↓ 2 Changed 7 years ago by rpc

UPDATE: This is the same guest running on 1.3.2 (i rolled back):

2963 rpc 19 0 399m 369m 3576 S 15 18.2 120:56.16 VBoxVRDP

And it stays like that, rock stable memory usage.

comment:2 in reply to: ↑ 1 Changed 7 years ago by frank

  • Owner set to frank
  • Status changed from new to assigned

Please could you retest with 1.3.6. There were some memory leak fixes for VRDP.

comment:3 Changed 7 years ago by klaus

  • Status changed from assigned to closed
  • Resolution set to fixed

User confirmed the memory leak is gone.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use