VirtualBox

Ticket #8199 (closed defect: fixed)

Opened 3 years ago

Last modified 13 months ago

Solaris 10 appliance complains that it doesn't support mouse integration on MacOS host

Reported by: yurivict Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.2 Keywords:
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

I talk about i386 MacOS and vbox-4.0.0 r69151. This message about mouse pointer integration pops up 2 times during guest boot. But actually this appliance has additions installed and for all practical purposes mouse is integrated. Mouse pointer doesn't get "stuck" in the window.

I believe this is a bug.

Attachments

VBox.log.4.0.2.still-mouse-integration-message Download (83.2 KB) - added by yurivict 3 years ago.
log file when the problem happens

Change History

comment:1 Changed 3 years ago by frank

Which guest additions are installed? Please attach the VBox.log file of such a VM session.

comment:2 Changed 3 years ago by yurivict

Actually original 3.0.8 additions were installed. But when I updated them to 4.0.2 nothing changed -- still the same messages about the mouse integration.

comment:3 Changed 3 years ago by yurivict

In addition the 4.0.2 additions cause solaris guest to work worse than the previous one (3.0.8). Both under 4.0.2 vbox. Before only this annoying message was coming up but everything worked, now guest can't switch to full screen mode. It complains that there is not enough memory to switch to full screen.

Changed 3 years ago by yurivict

log file when the problem happens

comment:4 Changed 3 years ago by yurivict

With 4.0.2 additions it asked for at least 6MB video memory instead of the previous 4MB. After I have set this it works fine. But messages about mouse integration are still there.

comment:5 Changed 3 years ago by yurivict

Confirmed warning about the lack of mouse integration with vbox-4.0.4 (with 4.0.4 additions)

comment:6 Changed 3 years ago by michael

Do you have an absolute pointing device enabled? If not, this could be happening because the guest fires up an X server, closes it again and restarts it. If an absolute pointing device is enabled (and the guest has a driver for it loaded) then you should never see such a window, although you may get multiple redundant messages about mouse integration being enabled. But currently there is no mouse integration without an X server or an absolute device.

comment:7 Changed 13 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use