VirtualBox

Ticket #8196 (closed task: invalid)

Opened 3 years ago

Last modified 3 years ago

Changes in VirtualBox webserver broke the virtualbox-plugin for Hudson

Reported by: mmzik Owned by:
Priority: major Component: webservices
Version: VirtualBox 4.0.2 Keywords: vboxwebsrv
Cc: Guest type: other
Host type: other

Description

Changes made from VirtualBox version 3.2+ to 4.0+ broke the virtualbox-plugin for Hudson. I highly suggest that you ensure compatibility, because a) both products Hudson and VirtualBox are made by your company and b) the virtualbox-plugin for Hudson should be considered as a key-plugin!

I created a issue on the Hudson-side too, please see here:  http://issues.hudson-ci.org/browse/HUDSON-8634

When Hudson (or to be precise the virtualbox-plugin) tries to connect to the VirtualBox-webserver (4.0+) the following exception-stack is dumped:

FATAL: HTTP transport error: java.net.ConnectException: Connection refused: connect com.sun.xml.internal.ws.client.ClientTransportException: HTTP transport error: java.net.ConnectException: Connection refused: connect at com.sun.xml.internal.ws.transport.http.client.HttpClientTransport.getOutput(HttpClientTransport.java:121) at com.sun.xml.internal.ws.transport.http.client.HttpTransportPipe.process(HttpTransportPipe.java:142) at com.sun.xml.internal.ws.transport.http.client.HttpTransportPipe.processRequest(HttpTransportPipe.java:83) at com.sun.xml.internal.ws.transport.DeferredTransportPipe.processRequest(DeferredTransportPipe.java:105) at com.sun.xml.internal.ws.api.pipe.Fiber.doRun(Fiber.java:587) at com.sun.xml.internal.ws.api.pipe.Fiber._doRun(Fiber.java:546) at com.sun.xml.internal.ws.api.pipe.Fiber.doRun(Fiber.java:531) at com.sun.xml.internal.ws.api.pipe.Fiber.runSync(Fiber.java:428) at com.sun.xml.internal.ws.client.Stub.process(Stub.java:211) at com.sun.xml.internal.ws.client.sei.SEIStub.doProcess(SEIStub.java:124) at com.sun.xml.internal.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:98) at com.sun.xml.internal.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:78) at com.sun.xml.internal.ws.client.sei.SEIStub.invoke(SEIStub.java:107) at $Proxy47.iWebsessionManagerLogon(Unknown Source) at com.sun.xml.ws.commons.virtualbox_3_1.IWebsessionManager.logon(IWebsessionManager.java:255) at hudson.plugins.virtualbox.VirtualBoxUtils.connect(VirtualBoxUtils.java:29) at hudson.plugins.virtualbox.VirtualBoxUtils.getMachines(VirtualBoxUtils.java:39) at hudson.plugins.virtualbox.VirtualBoxCloud.retrieveMachines(VirtualBoxCloud.java:56) at hudson.plugins.virtualbox.VirtualBoxCloud.getVirtualMachines(VirtualBoxCloud.java:61) at hudson.plugins.virtualbox.VirtualBoxPlugin.getVirtualBoxMachine(VirtualBoxPlugin.java:94) at hudson.plugins.virtualbox.VirtualBoxComputerLauncher.launch(VirtualBoxComputerLauncher.java:40) at hudson.slaves.SlaveComputer$1.call(SlaveComputer.java:184) at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303) at java.util.concurrent.FutureTask.run(FutureTask.java:138) at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) at java.lang.Thread.run(Thread.java:662) Caused by: java.net.ConnectException: Connection refused: connect at java.net.PlainSocketImpl.socketConnect(Native Method) at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333) at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195) at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182) at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366) at java.net.Socket.connect(Socket.java:529) at java.net.Socket.connect(Socket.java:478) at sun.net.NetworkClient.doConnect(NetworkClient.java:163) at sun.net.www.http.HttpClient.openServer(HttpClient.java:394) at sun.net.www.http.HttpClient.openServer(HttpClient.java:529) at sun.net.www.http.HttpClient.<init>(HttpClient.java:233) at sun.net.www.http.HttpClient.New(HttpClient.java:306) at sun.net.www.http.HttpClient.New(HttpClient.java:323) at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:975) at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:954) at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:841) at sun.net.www.protocol.http.HttpURLConnection.getOutputStream(HttpURLConnection.java:1019) at com.sun.xml.internal.ws.transport.http.client.HttpClientTransport.getOutput(HttpClientTransport.java:109) ... 26 more

Change History

comment:1 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid

Sorry, this is the wrong place to report this issue.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use