VirtualBox

Ticket #8194 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Vbox 4.02, Ubuntu 10.10 x64 guest live install hangs (on Windows 7 x64 host), requires acpi=off to fix

Reported by: heckheck Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.2 Keywords:
Cc: Guest type: other
Host type: other

Description

When attempting to install an Ubuntu 10.10 x64 guest on a Windows 7 x64 host using VBox 4.02, the Ubuntu installer consistently hangs as the kernel gets to line

Freeing initrd memory: 11516K freed

Adding the kernel boot option acpi=off (using f6 of the Ubuntu live CD installer) gets past this hang.

I had just upgraded this machine to VBox 4.02 from VBox 3.2.12, and just prior had NOT experienced this hang when installing using the same Ubuntu 10.10 x64 image on 3.2.12, so it may be a regression.

I also tried Ubuntu 10.04 x64 install media with VBox 4.02 and ran into the same problem.

I tried two version of 32bit Ubuntu 10.10 with VBox 4.02 (10.10 and a 10.04beta) and did not experience the problem (it only happens with the x64 versions).

I have not installed the 10.10 x64 fully, so I do not know if I will need the acpi=off kernel parameter once the OS is installed.

VBox.log attached for failing and passing (with acpi=off) case

Attachments

VBox.broke.log Download (75.9 KB) - added by heckheck 3 years ago.
Vbox log for live cd hung condition
VBox.acpi-off-works.log Download (76.0 KB) - added by heckheck 3 years ago.
Vbox log for working live cd boot with acpi=off kernel param added

Change History

Changed 3 years ago by heckheck

Vbox log for live cd hung condition

Changed 3 years ago by heckheck

Vbox log for working live cd boot with acpi=off kernel param added

comment:1 Changed 3 years ago by heckheck

Well this could well be an invalid ticket, but there is a subtle issue here. I just deleted and recreated the virtual machine again and realized I had not chosen

OS Type -> Version -> Ubuntu 64

instead I had been using

OS Type -> Version -> Ubuntu

So it appears that if the user makes this subtle mistake, they are in for a world of hurt (I just burned 3+ hours on this issue...). The automatic OS Type picker does a good job if you happen to put '64' in the name of the virtual machine (picking the Ubuntu 64 version), but I think that is too iffy a proposition.

In order to avoid user confusion and error, you really to put a big FAT warning nag screen up during machine creation, that warns the user of the potential disaster in not choosing the appropriate "version" (with a checkbox to disable showing that warning).

comment:2 Changed 3 years ago by heckheck

So at the very least, this is a bug of warning omission. It seems that if you don't choose the machine type appropriately for x64 guests, some things won't work properly (like ACPI). Since making the mistake is very easy to do, VBox either needs to autodetect 64bit install media and issue an error if there is a misconfiguration or be VERY proactive in warning the user of the potential problem.

comment:3 Changed 3 years ago by frank

Yes and no. Actually there is another bug which you triggered in some configurations and you did not in others. The bug I'm talking about is #8033. I will close this ticket as duplicate.

comment:4 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use