VirtualBox

Ticket #8155 (closed defect: wontfix)

Opened 3 years ago

Last modified 20 months ago

Bridged Network: VM uses MAC of Host instead of MAC entered in setting for the VM

Reported by: daSnoop Owned by:
Priority: major Component: network
Version: VirtualBox 4.0.2 Keywords: bridged network mac
Cc: mentioned since 4.0 Guest type: Linux
Host type: Linux

Description (last modified by frank) (diff)

Szenario:
DHCP on Router: Reservation for every Host in the Network
WLAN: MAC Access List
IP/MAC Binding: MAC bound to IP to prevent APR

Host uses WLAN to access the Network.
Both MAC's (Host & VM) are in the WLAN Mac Access List.
VM asks the DHCP for an IP with the correct MAC (entered in the Network Settings of the VM) and gets the correct IP.
After that the VM uses the MAC of the Host (as u can see in the picture. The Router's ARP List contains the IP from the VM with the MAC of the Host & the IP from the Host with the same MAC (window in the very backround))
The ARP list of the Host contains the IP from the VM with the MAC of the VM (window down right)
The VM says it has the MAC entered in the settings (window down left)

Because of that, IP/MAC binding isn't working because i have 2 different IP's with the same MAC.
I wonder why the VM tells the DHCP the correct MAC and after getting an IP it uses the MAC from the host.

That behavior first occured in 4.0. Before the update everything worked perfectly. Because it worked i never looked up wich MAC the VM uses in the previor versions.

Attachments

screenshot.png Download (237.4 KB) - added by daSnoop 3 years ago.

Change History

Changed 3 years ago by daSnoop

comment:1 Changed 3 years ago by aleksey

This behavior is by design and it has always been this way. Since the introduction of bridged networking VirtualBox substitutes guest's MAC with host's MAC for outgoing packets on Wi-Fi interfaces. This needs to be done because the majority of Wi-Fi adapters do not support promiscuous mode, hence they discard all packets with destination MAC different from host's.

PS. What's APR btw?

comment:2 Changed 20 months ago by frank

  • Status changed from new to closed
  • Resolution set to wontfix
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use