VirtualBox

Ticket #8154 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

The virtual machine reboots after starting Microsoft Visio 2007

Reported by: fayser Owned by:
Priority: major Component: VMM
Version: VirtualBox 4.0.2 Keywords: visio, crash
Cc: Guest type: Windows
Host type: Linux

Description

Host: Kubuntu 10.04 Guest: Windows XP SP3 with Guest Additions Oracle Virtualbox 4.0.2 with Oracle Extension Pack

A few seconds after starting Microsoft Visio 2007 the machine reboots or gets locked.

I downgraded to Virtualbox 4.0.0 and this not happens any more.

Attachments

Windows 7-2011-01-23-18-33-27.log Download (41.5 KB) - added by BrianJM 3 years ago.
Vbox.log
VBox.log.1 Download (71.2 KB) - added by fayser 3 years ago.
Visio 2007 reboot
VBox.log Download (71.8 KB) - added by sosoict 3 years ago.
log under fedora12
VBox.2.log Download (80.0 KB) - added by fayser 3 years ago.
4.0.4 reboot

Change History

Changed 3 years ago by BrianJM

Vbox.log

comment:1 Changed 3 years ago by BrianJM

I am having the same issue.

Host: Ubuntu 10.04 Kernel: 2.6.32-28-generic Guest OS: Windows 7

I attached my Vbox.log file. I have a core_dump available but it is greater than 5MB compressed. I can provide a download link to an admin/developer who contacts for me at the email address in my profile.

comment:2 Changed 3 years ago by frank

BrianJM, please contact me at frank _dot_ mehnert _at_ oracle _dot_ com.

fayser, your log does not show a guest reboot.

comment:3 Changed 3 years ago by BrianJM

frank,

I sent you an email with the link. I had to issue a "kill -4 <pid>" command to generate the dump because the guest continued to lock up.

comment:4 Changed 3 years ago by BrianJM

I can confirm that downgrading to 4.0 corrects the problem for me. I will have to stick with this release until the issue can be addressed. I use Visio daily!

comment:5 Changed 3 years ago by frank

In that case, could you try the VBoxManage instructions as written in #8008?

comment:6 Changed 3 years ago by BrianJM

Frank,

I completed the instructions and disabled power management in the guest. The guest freezes and the host CPU exceeds 100% for the VirtualBox process (100% of allocated resources) after closing Visio. Before this change the guest rebooted (my previous 2011-01-24 17:17:46 response stated that the guest locked up but this was a typo). After ~3 minutes I had to end the process.

This may have been a fluke, but this is the first time the guest locked up in over a dozen attempts.

comment:7 Changed 3 years ago by fayser

After a couple of days working with 4.0.0 I upgraded again to 4.0.2, and Visio no longer crashes or reboots the machine...

I have no idea of what happened, I am trying to reproduce the problem installing a new VM from scratch.

Changed 3 years ago by fayser

Visio 2007 reboot

comment:8 Changed 3 years ago by fayser

I managed to reproduce the problem.

I got a VM working properly, I cloned the HD, I executed the VM with a different user... and after starting Visio 2007 it rebooted.

I attach the log.

comment:9 Changed 3 years ago by aric.aversa

I am also experiencing this issue. VM reboots while using Visio.

VirtualBox 4.0.2 r69518, Guest: Windows 7 Professional, Visio 2007 SP 2

comment:10 Changed 3 years ago by dpaxton

Same issue here. Reboots launching Visio 2007 on Microsoft Windows 7 guest.

Virtualbox 4.0.2 r69518 running on OSX 10.6.6

comment:11 Changed 3 years ago by frank

Still not sure if this is really related to #8008. From some comments above it looks like there is a different cause. Please could you install a test build of the upcoming 4.0.4 release and check if you still experience these reboots? Here is one build for  Mac OS X and one for  Ubuntu 10.04/64-bit.

comment:12 in reply to: ↑ description Changed 3 years ago by sosoict

I met the same problem with visio 2003 under Fedora12,Fedora14 and Redhat5 32bit. I tried vbox 4.0.0 and 3.2.12 and the problem occurred too.

Hoping resolved in the coming version.

comment:13 follow-up: ↓ 14 Changed 3 years ago by frank

Did anyone try the test builds I provided?

Changed 3 years ago by sosoict

log under fedora12

comment:14 in reply to: ↑ 13 Changed 3 years ago by sosoict

frank,is there a build for fedora12/14 or redhat? I would like to try. Replying to frank:

Did anyone try the test builds I provided?

comment:15 in reply to: ↑ description Changed 3 years ago by sosoict

It's strange that if start visio by opening an existed visio document, it won't cause rebooting and visio works well.

comment:16 follow-up: ↓ 17 Changed 3 years ago by frank

 Here is a Fedora 14 test build.

comment:17 in reply to: ↑ 16 Changed 3 years ago by sosoict

I tried, but the problem seems not resolved...

Replying to frank:

 Here is a Fedora 14 test build.

comment:18 follow-ups: ↓ 19 ↓ 20 ↓ 21 Changed 3 years ago by frank

That's bad, so this problem has another cause. Unfortunately we don't have that software for testing. Is there a trial version where these reboots could be reproduced?

comment:19 in reply to: ↑ 18 Changed 3 years ago by sosoict

 http://www.microsoft.com/downloads/en/confirmation.aspx?FamilyID=6b01bcc2-442a-4a8a-9ca7-51463fdd1416&hash=uVC1aoPgHA7IZ%2by9ymrPdxOimX3lt8kIutlz7iClCC7ORHAX23158%2bmJcbOlGXdCJNhCvFtjMSxdQSwHU4Jy%2fw%3d%3d

the above is trial version of visio2010,but I have not tried whether this version causes rebooting. I'll try later after downloading it.

btw, there seems to be some sites for downloading vision2003 by using searching engine(such as google), but I havn't try.

Replying to frank:

That's bad, so this problem has another cause. Unfortunately we don't have that software for testing. Is there a trial version where these reboots could be reproduced?

comment:20 in reply to: ↑ 18 Changed 3 years ago by BrianJM

Replying to frank:

That's bad, so this problem has another cause. Unfortunately we don't have that software for testing. Is there a trial version where these reboots could be reproduced?

You can download a trial version of Visio 2007 from CNET.

 http://download.cnet.com/Microsoft-Office-Visio-Professional-2007/3000-2064_4-10704836.html

comment:21 in reply to: ↑ 18 Changed 3 years ago by sosoict

visio2010 dosn't cause vbox rebooting

comment:22 Changed 3 years ago by fayser

Updated to 4.0.4, but it is still broken. Visio reboots, I'll attach the log.

Changed 3 years ago by fayser

4.0.4 reboot

comment:23 follow-up: ↓ 24 Changed 3 years ago by frank

Reproduced using the provided 2007 trial link. Thanks.

comment:24 in reply to: ↑ 23 Changed 3 years ago by psalzman

I am experiencing the same problem and did not have this issue in 3.2. I downgraded to 4.0.0 and the VM still crashes. Unfortunately, I cannot seem to downgrade back to 3.2 as my VMs do not load.

Replying to frank:

Reproduced using the provided 2007 trial link. Thanks.

comment:25 Changed 3 years ago by cenoura

I had the same issue (vbox 4.0.2 and guest additions 4.0.2) with my XP box... I've also tried to downgrade to 3.2 without success (same problem as psalzman). Now I'm running 4.0.4.
Although I've uninstalled the guest additions 4.0.2 on my XP box and installed the 3.2.8 and seems to solve the reboot issue. I've worked with visio 4 hours without any issue.
I've downloaded GA 3.28  here
Sorry for my bad english and hope it helps

comment:26 Changed 3 years ago by sunlover

Please try the following guest additions:

 http://www.virtualbox.org/download/testcase/VBoxGuestAdditions-r70636.iso

Most likely the problem is fixed there.

comment:27 Changed 3 years ago by fayser

It seems to fix the issue, after installing those guest additions it didn't reboot. I have to test it more thoroughly anyway.

comment:28 Changed 3 years ago by dsorber

I was encountering the issue with version 4.0.4 and after upgrade to the VBoxGuestAdditions linked above, the problem seems to be fixed.

comment:29 Changed 3 years ago by tcm5025

this fixed it for me as well. thank you!

comment:30 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

The is part of VBox 4.0.6 so we can close this ticket.

comment:31 Changed 2 years ago by Subbeh

VBoxGuestAdditions-r70636.iso seems to be removed from the site, does anyone have a mirror?

comment:32 Changed 2 years ago by frank

Did you actually read the last comment? That test build is not necessary anymore since the fix was included in the normal release builds long time ago. VBox 4.0.14 and VBox 4.1.6 have it included.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use